aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mx2
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
commite2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f (patch)
treef8563604e7685c30b0a2a675ca80379a34114565 /target/linux/mx2
parent040c06438896144dfe148910f922a0d9bb0058b0 (diff)
downloadupstream-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.gz
upstream-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.bz2
upstream-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.zip
define a shared IMG_PREFIX variable used as a basename for image files, it contains board & subtarget infos (if appropriate) allowing subtargets to share the same bin directory without overwriting each other's files
SVN-Revision: 20834
Diffstat (limited to 'target/linux/mx2')
-rw-r--r--target/linux/mx2/image/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/target/linux/mx2/image/Makefile b/target/linux/mx2/image/Makefile
index 12fbe4ee4f..70636ae4d6 100644
--- a/target/linux/mx2/image/Makefile
+++ b/target/linux/mx2/image/Makefile
@@ -1,3 +1,9 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
@@ -7,7 +13,7 @@ JFFS2OPTS += -n
define Image/BuildKernel
mkdir -p $(BIN_DIR)
- cp $(KDIR)/vmlinuz $(BIN_DIR)/openwrt-$(BOARD)-zImage
+ cp $(KDIR)/vmlinuz $(BIN_DIR)/$(IMG_PREFIX)-zImage
endef
define Image/Prepare
@@ -16,7 +22,7 @@ endef
define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-root.$(1))
+ $(call prepare_generic_squashfs,$(BIN_DIR)/$(IMG_PREFIX)-root.$(1))
endef
$(eval $(call BuildImage))