aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-01-17 14:43:36 +0100
committerMathias Kresin <dev@kresin.me>2019-01-26 10:45:34 +0100
commit650df59e8a541e56b854ca03495c29db2f7cb846 (patch)
tree9c037d48b4ef92cdf810ebd9776fd8dbb6cc38ec /target/linux/mvebu
parent25eb02ae8e59031252d64a5be047c0f99eb6d827 (diff)
downloadupstream-650df59e8a541e56b854ca03495c29db2f7cb846.tar.gz
upstream-650df59e8a541e56b854ca03495c29db2f7cb846.tar.bz2
upstream-650df59e8a541e56b854ca03495c29db2f7cb846.zip
mvebu: remove default profile
When using Image Builder and building image for Cortex A53 or A72 subtargets, it'll fail with following message: Collected errors: * opkg_install_cmd: Cannot install package mwlwifi-firmware-88w8864. * opkg_install_cmd: Cannot install package mwlwifi-firmware-88w8964. make[2]: *** [Makefile:153: package_install] Error 255 make[1]: *** [Makefile:114: _call_image] Error 2 This is beacuse both packages are available only for Cortex A9 subtarget and are included in PACKAGES array in default profile. Instead patching this, let's remove profiles completely, since all necessary packages are specified in DEVICE_PACKAGES array for each device. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/mvebu')
-rw-r--r--target/linux/mvebu/profiles/000-Default.mk18
1 files changed, 0 insertions, 18 deletions
diff --git a/target/linux/mvebu/profiles/000-Default.mk b/target/linux/mvebu/profiles/000-Default.mk
deleted file mode 100644
index 8690dd8da5..0000000000
--- a/target/linux/mvebu/profiles/000-Default.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
- NAME:=Default Profile (all drivers)
- PACKAGES:= kmod-mwlwifi wpad-basic swconfig mkf2fs e2fsprogs \
- mwlwifi-firmware-88w8864 mwlwifi-firmware-88w8964
-endef
-
-define Profile/Default/Description
- Default package set compatible with most boards.
-endef
-
-$(eval $(call Profile,Default))