aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortex-a9.mk
diff options
context:
space:
mode:
authorMichael Gray <michael.gray@lantisproject.com>2018-05-13 23:29:30 +1000
committerJohn Crispin <john@phrozen.org>2018-05-14 17:20:10 +0200
commitbfbdeeb3de3da31f7e5f9bd429e079c2d839644a (patch)
tree4ce9728ecd6879d2215a9151eb700cde9c2e9273 /target/linux/mvebu/image/cortex-a9.mk
parente1a9485b0e23115787a8488c5988b2411e318519 (diff)
downloadupstream-bfbdeeb3de3da31f7e5f9bd429e079c2d839644a.tar.gz
upstream-bfbdeeb3de3da31f7e5f9bd429e079c2d839644a.tar.bz2
upstream-bfbdeeb3de3da31f7e5f9bd429e079c2d839644a.zip
mvebu: add support for WRT32X (venom)
Linksys WRT32X (Venom) is identical in hardware to the WRT3200ACM with a different flash layout and boots zImage rather than uImage. Specification: - Marvell Armada 385 88F6820 (2x 1.8GHz) - 256MB of Flash - 512MB of RAM - 2.4GHz (bgn) and 5GHz (an+ac wave 2) - 4x 1Gbps LAN + 1x 1Gbps WAN - 1x USB 3.0 and 1x USB 2.0/eSATA (combo port) Flash instruction: Apply factory image via web-gui. Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
Diffstat (limited to 'target/linux/mvebu/image/cortex-a9.mk')
-rw-r--r--target/linux/mvebu/image/cortex-a9.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/cortex-a9.mk b/target/linux/mvebu/image/cortex-a9.mk
index d9defe880d..6bc6269da6 100644
--- a/target/linux/mvebu/image/cortex-a9.mk
+++ b/target/linux/mvebu/image/cortex-a9.mk
@@ -51,6 +51,16 @@ define Device/linksys-wrt1900acs
endef
TARGET_DEVICES += linksys-wrt1900acs
+define Device/linksys-wrt32x
+$(call Device/linksys,WRT32X (Venom))
+ DEVICE_DTS := armada-385-linksys-venom
+ DEVICE_PACKAGES += kmod-btmrvl kmod-mwifiex-sdio mwlwifi-firmware-88w8964
+ $(Device/armada-385-linksys)
+ KERNEL_SIZE := 3072k
+ KERNEL := kernel-bin | append-dtb
+endef
+TARGET_DEVICES += linksys-wrt32x
+
define Device/linksys-wrt1900ac
$(call Device/linksys,WRT1900AC (Mamba))
DEVICE_DTS := armada-xp-linksys-mamba