aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortex-a72.mk
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2020-01-31 16:46:13 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-01 20:01:58 +0100
commit67ac189e4ba8f49db428869de0837b85f3b827c7 (patch)
tree6e07666a38508866f3092dc700891cc3e27bcd00 /target/linux/mvebu/image/cortex-a72.mk
parent6d6f36ae787c3b339b16c1d345a90faa1d9f4011 (diff)
downloadupstream-67ac189e4ba8f49db428869de0837b85f3b827c7.tar.gz
upstream-67ac189e4ba8f49db428869de0837b85f3b827c7.tar.bz2
upstream-67ac189e4ba8f49db428869de0837b85f3b827c7.zip
mvebu: image: sort devices alphabetically
This sorts the devices in image Makefiles alphabetically. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl> [fixed sorting in one case, add commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/mvebu/image/cortex-a72.mk')
-rw-r--r--target/linux/mvebu/image/cortex-a72.mk30
1 files changed, 15 insertions, 15 deletions
diff --git a/target/linux/mvebu/image/cortex-a72.mk b/target/linux/mvebu/image/cortex-a72.mk
index 6abee2d8b9..a7a4d7c2e7 100644
--- a/target/linux/mvebu/image/cortex-a72.mk
+++ b/target/linux/mvebu/image/cortex-a72.mk
@@ -1,14 +1,11 @@
-define Device/marvell_macchiatobin
+define Device/marvell_armada7040-db
$(call Device/Default-arm64)
- DEVICE_VENDOR := SolidRun
- DEVICE_MODEL := MACCHIATObin
- DEVICE_ALT0_VENDOR := SolidRun
- DEVICE_ALT0_MODEL := Armada 8040 Community Board
- DEVICE_PACKAGES += kmod-i2c-core kmod-i2c-mux kmod-i2c-mux-pca954x
- DEVICE_DTS := armada-8040-mcbin
- SUPPORTED_DEVICES := marvell,armada8040-mcbin
+ DEVICE_VENDOR := Marvell
+ DEVICE_MODEL := Armada 7040 Development Board
+ DEVICE_DTS := armada-7040-db
+ IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
endef
-TARGET_DEVICES += marvell_macchiatobin
+TARGET_DEVICES += marvell_armada7040-db
define Device/marvell_armada8040-db
$(call Device/Default-arm64)
@@ -19,11 +16,14 @@ define Device/marvell_armada8040-db
endef
TARGET_DEVICES += marvell_armada8040-db
-define Device/marvell_armada7040-db
+define Device/marvell_macchiatobin
$(call Device/Default-arm64)
- DEVICE_VENDOR := Marvell
- DEVICE_MODEL := Armada 7040 Development Board
- DEVICE_DTS := armada-7040-db
- IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
+ DEVICE_VENDOR := SolidRun
+ DEVICE_MODEL := MACCHIATObin
+ DEVICE_ALT0_VENDOR := SolidRun
+ DEVICE_ALT0_MODEL := Armada 8040 Community Board
+ DEVICE_PACKAGES += kmod-i2c-core kmod-i2c-mux kmod-i2c-mux-pca954x
+ DEVICE_DTS := armada-8040-mcbin
+ SUPPORTED_DEVICES := marvell,armada8040-mcbin
endef
-TARGET_DEVICES += marvell_armada7040-db
+TARGET_DEVICES += marvell_macchiatobin