aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/Makefile
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-05-11 19:37:32 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-11 23:11:04 +0200
commit30b5554411192415ce70f16c1b48b11ce013bbf2 (patch)
tree054b3a0f69db1ffb02f828b656fe7e8d8f5ff5f2 /target/linux/mvebu/image/Makefile
parent9509a6df0bff483fc165bc5da98f03d2d736622f (diff)
downloadupstream-30b5554411192415ce70f16c1b48b11ce013bbf2.tar.gz
upstream-30b5554411192415ce70f16c1b48b11ce013bbf2.tar.bz2
upstream-30b5554411192415ce70f16c1b48b11ce013bbf2.zip
mvebu: image: don't create unnecessarily shell variables
Use make syntax to pass the U-Boot image location and boot with root partitions size, instead of relying on shell functions and variables. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/mvebu/image/Makefile')
-rw-r--r--target/linux/mvebu/image/Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 108b569c07..9084b3e028 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -42,25 +42,19 @@ define Build/boot-img-ext4
endef
define Build/sdcard-img
- if [ -n "$(UBOOT)" ]; then UBOOT="$(STAGING_DIR_IMAGE)/$(UBOOT)"; fi; \
- BOOTFS_SIZE=$$(( $(CONFIG_TARGET_KERNEL_PARTSIZE) * 1024 * 2 )); \
- ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
SIGNATURE="$(SIGNATURE)" \
./gen_mvebu_sdcard_img.sh $@ \
- $$UBOOT \
- c $$BOOTFS_SIZE $@.boot \
- 83 $$ROOTFS_SIZE $(IMAGE_ROOTFS)
+ $(if $(UBOOT),$(STAGING_DIR_IMAGE)/$(UBOOT)) \
+ c $(CONFIG_TARGET_KERNEL_PARTSIZE) $@.boot \
+ 83 $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(IMAGE_ROOTFS)
endef
define Build/sdcard-img-ext4
- if [ -n "$(UBOOT)" ]; then UBOOT="$(STAGING_DIR_IMAGE)/$(UBOOT)"; fi; \
- BOOTFS_SIZE=$$(( $(CONFIG_TARGET_KERNEL_PARTSIZE) * 1024 * 2 )); \
- ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
SIGNATURE="$(SIGNATURE)" \
./gen_mvebu_sdcard_img.sh $@ \
- $$UBOOT \
- 83 $$BOOTFS_SIZE $@.bootimg \
- 83 $$ROOTFS_SIZE $(IMAGE_ROOTFS)
+ $(if $(UBOOT),$(STAGING_DIR_IMAGE)/$(UBOOT)) \
+ 83 $(CONFIG_TARGET_KERNEL_PARTSIZE) $@.bootimg \
+ 83 $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(IMAGE_ROOTFS)
endef
define Build/omnia-medkit-initramfs