aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-01-08 22:20:16 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-01-08 22:20:16 +0000
commit91e3a3252f68589aaa7d5131cbe77c2c552c1df4 (patch)
treea5cbc0f5235b30a249d4532479600f183be2eec6 /target/linux/mvebu/Makefile
parentb5988e0640bd2ad96cc2c0b79197873f7ab9085c (diff)
downloadupstream-91e3a3252f68589aaa7d5131cbe77c2c552c1df4.tar.gz
upstream-91e3a3252f68589aaa7d5131cbe77c2c552c1df4.tar.bz2
upstream-91e3a3252f68589aaa7d5131cbe77c2c552c1df4.zip
mvebu: add inital support for Marvell Armada XP/370 SoCs
This brings in the initial support for the Marvell Armada XP/370 SoCs. Successfully tested on RD-A370-A1 and DB-MV784MP-GP boards the following interfaces: - Ethernet - SDIO - GPIOs - SATA Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35058 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mvebu/Makefile')
-rw-r--r--target/linux/mvebu/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/mvebu/Makefile b/target/linux/mvebu/Makefile
new file mode 100644
index 0000000000..4ff5fe20a1
--- /dev/null
+++ b/target/linux/mvebu/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=mvebu
+BOARDNAME:=Marvell Armada XP/370 boards
+FEATURES:=targz usb jffs2 pci pcie gpio
+CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+
+LINUX_VERSION:=3.8-rc2
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="zImage dtbs"
+
+DEFAULT_PACKAGES +=
+
+$(eval $(call BuildTarget))