aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2019-07-04 13:17:02 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-07-07 13:02:05 +0200
commitb683f1c36d8a791f3d8b53c2c2748fa89bcf94af (patch)
tree2715e275919ee5aa01375dfe1ddb95713e3365ab /target/linux/mpc85xx
parent94d131332b5adbcf885a92608c40a22b79b3c708 (diff)
downloadupstream-b683f1c36d8a791f3d8b53c2c2748fa89bcf94af.tar.gz
upstream-b683f1c36d8a791f3d8b53c2c2748fa89bcf94af.tar.bz2
upstream-b683f1c36d8a791f3d8b53c2c2748fa89bcf94af.zip
mpc85xx: Use gzip compressed kernel on HiveAP-330
After commit 1e41de2f48 ("mpc85xx: convert TL-WDR4900 v1 to simpleImage") XZ compression of zImage was enabled. This change exposed a problem with the HiveAP-330 images, which was fixed by foregoing the compression on the kernel altogether with commit 98089bb8ba8 ("mpc85xx: Use uncompressed kernel on the HiveAP-330"). This patch adds back the gzip compression of the kernel image by utilizing the generic OpenWRT uImage method instead of relying on the PowerPC bootwrapper script that did it previously. Compile-tested: p1020/hiveap-330 Tested-by: Chris Blake <chrisrblake93@gmail.com> [run-tested] Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [filled in even more text]
Diffstat (limited to 'target/linux/mpc85xx')
-rw-r--r--target/linux/mpc85xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index c582d7a592..c2ddcb32c5 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -85,7 +85,7 @@ define Device/hiveap-330
DEVICE_TITLE := Aerohive HiveAP-330
DEVICE_PACKAGES := kmod-tpm-i2c-atmel
BLOCKSIZE := 128k
- KERNEL := kernel-bin | uImage none
+ KERNEL := kernel-bin | gzip | uImage gzip
KERNEL_SIZE := 8m
KERNEL_INITRAMFS := copy-file $(KDIR)/vmlinux-initramfs | uImage none
SUPPORTED_DEVICES := aerohive,hiveap-330