aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2019-01-17 01:01:18 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2019-01-17 03:04:13 +0200
commita37098a2d013f89a97ee001d5fb0980e538d2dee (patch)
treedc6dd90582fd78f3b69364328f4415a9dfcb4dd7 /target/linux/mpc85xx
parent76cc7665211266c810e59ebd74b810f69aaf8706 (diff)
downloadupstream-a37098a2d013f89a97ee001d5fb0980e538d2dee.tar.gz
upstream-a37098a2d013f89a97ee001d5fb0980e538d2dee.tar.bz2
upstream-a37098a2d013f89a97ee001d5fb0980e538d2dee.zip
kernel: bump 4.19 to 4.19.16
Refresh patches. Remove upstreamed patches: - backport/096-mips-math-emu-Write-protect-delay-slot-emulation-pages.patch - backport/096-v4.20-netfilter-ipv6-Preserve-link-scope-traffic-original-.patch - backport/424-v4.20-net-dsa-fix-88e6060-roaming.patch - hack/100-mtd-rawnand-qcom-fix-memory-corruption-that-causes-p.patch - pending/510-f2fs-fix-sanity_check_raw_super-on-big-endian-machines.patch Update patch that no longer applies: - backport/343-netfilter-nft_flow_offload-handle-netdevice-events-f.patch Compile-tested: mesongx Runtime-tested: mesongx Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'target/linux/mpc85xx')
-rw-r--r--target/linux/mpc85xx/patches-4.19/100-powerpc-85xx-tl-wdr4900-v1-support.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/target/linux/mpc85xx/patches-4.19/100-powerpc-85xx-tl-wdr4900-v1-support.patch b/target/linux/mpc85xx/patches-4.19/100-powerpc-85xx-tl-wdr4900-v1-support.patch
index ddcc7f363c..6d76ebc32c 100644
--- a/target/linux/mpc85xx/patches-4.19/100-powerpc-85xx-tl-wdr4900-v1-support.patch
+++ b/target/linux/mpc85xx/patches-4.19/100-powerpc-85xx-tl-wdr4900-v1-support.patch
@@ -17,7 +17,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
--- a/arch/powerpc/boot/Makefile
+++ b/arch/powerpc/boot/Makefile
-@@ -159,6 +159,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
+@@ -164,6 +164,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
src-plat-$(CONFIG_PPC_POWERNV) += pseries-head.S
src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
@@ -25,7 +25,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
src-wlib := $(sort $(src-wlib-y))
src-plat := $(sort $(src-plat-y))
-@@ -338,7 +338,7 @@ image-$(CONFIG_TQM8555) += cuImage.tqm
+@@ -343,7 +344,7 @@ image-$(CONFIG_TQM8555) += cuImage.tqm
image-$(CONFIG_TQM8560) += cuImage.tqm8560
image-$(CONFIG_SBC8548) += cuImage.sbc8548
image-$(CONFIG_KSI8560) += cuImage.ksi8560
@@ -49,10 +49,10 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
;;
--- a/arch/powerpc/platforms/85xx/Kconfig
+++ b/arch/powerpc/platforms/85xx/Kconfig
-@@ -170,6 +181,18 @@ config STX_GP3
- select CPM2
- select DEFAULT_UIMAGE
-
+@@ -170,6 +170,18 @@ config STX_GP3
+ select CPM2
+ select DEFAULT_UIMAGE
+
+config TL_WDR4900_V1
+ bool "TP-Link TL-WDR4900 v1"
+ select DEFAULT_UIMAGE
@@ -66,8 +66,8 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
+ Freescale P1014 SoC.
+
config TQM8540
- bool "TQ Components TQM8540"
- help
+ bool "TQ Components TQM8540"
+ help
--- a/arch/powerpc/platforms/85xx/Makefile
+++ b/arch/powerpc/platforms/85xx/Makefile
@@ -26,6 +26,7 @@ obj-$(CONFIG_CORENET_GENERIC) += coren