aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/patches-5.4/900-powerpc-bootwrapper-disable-uImage-generation.patch
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-02-29 14:32:15 +0100
committerDavid Bauer <mail@david-bauer.net>2020-03-01 00:51:23 +0100
commitab27c72debf44c33fb2b926b78adca973accf58b (patch)
treef218decb9cdf4420bdf0b26df949946bd5d41f0b /target/linux/mpc85xx/patches-5.4/900-powerpc-bootwrapper-disable-uImage-generation.patch
parent0d727f231fe94f7e9d51b251f0dbcc3a2f31e9eb (diff)
downloadupstream-ab27c72debf44c33fb2b926b78adca973accf58b.tar.gz
upstream-ab27c72debf44c33fb2b926b78adca973accf58b.tar.bz2
upstream-ab27c72debf44c33fb2b926b78adca973accf58b.zip
mpc85xx: disable kernel uImage generation
The previous workaround for the unsupported mkimage xz compression leads to the TP-Link TL-WDR4900s simpleImage bootwrapper being gzip compressed, which does not fit the kernel partition. Removing the uImage gerneration works around this problem. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/mpc85xx/patches-5.4/900-powerpc-bootwrapper-disable-uImage-generation.patch')
-rw-r--r--target/linux/mpc85xx/patches-5.4/900-powerpc-bootwrapper-disable-uImage-generation.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/patches-5.4/900-powerpc-bootwrapper-disable-uImage-generation.patch b/target/linux/mpc85xx/patches-5.4/900-powerpc-bootwrapper-disable-uImage-generation.patch
new file mode 100644
index 0000000000..6bbacdaf9a
--- /dev/null
+++ b/target/linux/mpc85xx/patches-5.4/900-powerpc-bootwrapper-disable-uImage-generation.patch
@@ -0,0 +1,42 @@
+From d43ab14605510d9d2bd257a8cd70f24ada4621b0 Mon Sep 17 00:00:00 2001
+From: David Bauer <mail@david-bauer.net>
+Date: Sat, 29 Feb 2020 14:27:04 +0100
+Subject: [PATCH] powerpc: bootwrapper: disable uImage generation
+
+Due to CONFIG_KERNEL_XZ symbol, the bootwrapper code tries to
+instruct the mkimage to use the xz compression, which isn't
+supported. This disables the uImage generation, as OpenWrt
+generates individual uImages for each board using it's own
+toolchain.
+
+Signed-off-by: David Bauer <mail@david-bauer.net>
+---
+ arch/powerpc/boot/Makefile | 9 ---------
+ 1 file changed, 9 deletions(-)
+
+--- a/arch/powerpc/boot/Makefile
++++ b/arch/powerpc/boot/Makefile
+@@ -268,7 +268,6 @@ image-$(CONFIG_PPC_CHRP) += zImage.chrp
+ image-$(CONFIG_PPC_EFIKA) += zImage.chrp
+ image-$(CONFIG_PPC_PMAC) += zImage.pmac
+ image-$(CONFIG_PPC_HOLLY) += dtbImage.holly
+-image-$(CONFIG_DEFAULT_UIMAGE) += uImage
+ image-$(CONFIG_EPAPR_BOOT) += zImage.epapr
+
+ #
+@@ -397,15 +396,6 @@ $(obj)/dtbImage.%: vmlinux $(wrapperbits
+ $(obj)/vmlinux.strip: vmlinux
+ $(STRIP) -s -R .comment $< -o $@
+
+-$(obj)/uImage: vmlinux $(wrapperbits) FORCE
+- $(call if_changed,wrap,uboot)
+-
+-$(obj)/uImage.initrd.%: vmlinux $(obj)/dts/%.dtb $(wrapperbits) FORCE
+- $(call if_changed,wrap,uboot-$*,,$(obj)/dts/$*.dtb,$(obj)/ramdisk.image.gz)
+-
+-$(obj)/uImage.%: vmlinux $(obj)/dts/%.dtb $(wrapperbits) FORCE
+- $(call if_changed,wrap,uboot-$*,,$(obj)/dts/$*.dtb)
+-
+ $(obj)/cuImage.initrd.%: vmlinux $(obj)/dts/%.dtb $(wrapperbits) FORCE
+ $(call if_changed,wrap,cuboot-$*,,$(obj)/dts/$*.dtb,$(obj)/ramdisk.image.gz)
+