aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc52xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-07-28 15:51:32 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-07-28 15:51:32 +0000
commita63f8633f06f5f785391c006fad57333a2cebc46 (patch)
tree22943e07bc8bd2c0955d051844ba9e8297e02c5e /target/linux/mpc52xx/image
parent57eaa31a128a601148d87a884ccdb5c06f371be0 (diff)
downloadupstream-a63f8633f06f5f785391c006fad57333a2cebc46.tar.gz
upstream-a63f8633f06f5f785391c006fad57333a2cebc46.tar.bz2
upstream-a63f8633f06f5f785391c006fad57333a2cebc46.zip
add new target for Freescale MPC52xx based boards
SVN-Revision: 17037
Diffstat (limited to 'target/linux/mpc52xx/image')
-rw-r--r--target/linux/mpc52xx/image/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/mpc52xx/image/Makefile b/target/linux/mpc52xx/image/Makefile
new file mode 100644
index 0000000000..177ca07bb7
--- /dev/null
+++ b/target/linux/mpc52xx/image/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/powerpc/boot/zImage $(KDIR)/zImage
+endef
+
+define Image/BuildKernel
+ cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
+endef
+
+define Image/Build/ext2
+ cp $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-ext2.img
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+$(eval $(call BuildImage))