aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-01-31 00:45:10 +0000
committerDaniel Golle <daniel@makrotopia.org>2022-01-31 15:02:36 +0000
commit9ba7a834254de33a3578a1a5884a39dc88ef7caf (patch)
treeb77f6c6eb620f885390e9457dbf9763edf567afa /target/linux/mediatek
parent5d110c016184fc2f072a41b77fce322b439bc225 (diff)
downloadupstream-9ba7a834254de33a3578a1a5884a39dc88ef7caf.tar.gz
upstream-9ba7a834254de33a3578a1a5884a39dc88ef7caf.tar.bz2
upstream-9ba7a834254de33a3578a1a5884a39dc88ef7caf.zip
mediatek: mt7623: simplify partition generation
The two options 'emmc' and 'sdmmc' now became identical lines after introducing CONFIG_TARGET_ROOTFS_PARTSIZE. Remove the now useless if-clauses. Fixes: a40b4d335a ("mediatek: use CONFIG_TARGET_ROOTFS_PARTSIZE") Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/mediatek')
-rw-r--r--target/linux/mediatek/image/mt7623.mk7
1 files changed, 1 insertions, 6 deletions
diff --git a/target/linux/mediatek/image/mt7623.mk b/target/linux/mediatek/image/mt7623.mk
index 16f59790b0..4ef0aabe4d 100644
--- a/target/linux/mediatek/image/mt7623.mk
+++ b/target/linux/mediatek/image/mt7623.mk
@@ -57,12 +57,7 @@ define Build/mt7623-mbr
ptgen -o $@.tmp -h 4 -s 63 -a 0 -l 1024 \
-t 0x41 -N uboot -p 1M@$(UBOOT_OFFSET) \
-t 0xea -N recovery -p 40M@4M \
- $(if $(findstring sdmmc,$1), \
- -t 0x2e -N production -p $(CONFIG_TARGET_ROOTFS_PARTSIZE)M@48M \
- ) \
- $(if $(findstring emmc,$1), \
- -t 0x2e -N production -p $(CONFIG_TARGET_ROOTFS_PARTSIZE)M@48M \
- )
+ -t 0x2e -N production -p $(CONFIG_TARGET_ROOTFS_PARTSIZE)M@48M
echo -en \
$(if $(findstring sdmmc,$1),"SDMMC_BOOT\x00\x00\x01\x00\x00\x00\x00\x02\x00\x00") \