aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek
diff options
context:
space:
mode:
authorStijn Segers <francesco.borromini@inventati.org>2016-09-30 08:34:01 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2016-09-30 13:34:04 +0200
commit949cfbb24374be151e2c01db09dd98bc8537a989 (patch)
tree8a87fc4295daec2beee33827e85592f2b932a791 /target/linux/mediatek
parentfc88eb3fdfce6d39b4c62158cf6f42605a360a1e (diff)
downloadupstream-949cfbb24374be151e2c01db09dd98bc8537a989.tar.gz
upstream-949cfbb24374be151e2c01db09dd98bc8537a989.tar.bz2
upstream-949cfbb24374be151e2c01db09dd98bc8537a989.zip
kernel: update kernel 4.4 to version 4.4.22
Forgot to update kernel-version.mk, so updated patch. Compile-tested on x86/64 and ar71xx; run-tested on x86/64 and ar71xx. Signed-off-by: Stijn Segers <francesco.borromini@inventati.org>
Diffstat (limited to 'target/linux/mediatek')
-rw-r--r--target/linux/mediatek/patches-4.4/0019-xhci-mediatek-support-MTK-xHCI-host-controller.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/mediatek/patches-4.4/0019-xhci-mediatek-support-MTK-xHCI-host-controller.patch b/target/linux/mediatek/patches-4.4/0019-xhci-mediatek-support-MTK-xHCI-host-controller.patch
index c107c7ce87..055ea03835 100644
--- a/target/linux/mediatek/patches-4.4/0019-xhci-mediatek-support-MTK-xHCI-host-controller.patch
+++ b/target/linux/mediatek/patches-4.4/0019-xhci-mediatek-support-MTK-xHCI-host-controller.patch
@@ -1428,7 +1428,7 @@ Reviewed-by: Daniel Thompson <daniel.thompson@linaro.org>
/*
* Returns zero if the TRB isn't in this segment, otherwise it returns the DMA
-@@ -3084,17 +3085,22 @@ static u32 xhci_td_remainder(struct xhci
+@@ -3088,17 +3089,22 @@ static u32 xhci_td_remainder(struct xhci
{
u32 maxp, total_packet_count;
@@ -1455,7 +1455,7 @@ Reviewed-by: Daniel Thompson <daniel.thompson@linaro.org>
/* Queueing functions don't count the current TRB into transferred */
return (total_packet_count - ((transferred + trb_buff_len) / maxp));
}
-@@ -3482,7 +3488,7 @@ int xhci_queue_ctrl_tx(struct xhci_hcd *
+@@ -3486,7 +3492,7 @@ int xhci_queue_ctrl_tx(struct xhci_hcd *
field |= 0x1;
/* xHCI 1.0/1.1 6.4.1.2.1: Transfer Type field */