aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2023-06-15 16:11:27 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-11-13 14:10:56 +0100
commit3555a2930f9ccefaabe4400364e1e2b29692b5de (patch)
tree2d4d6ff777ac17bcf159d6e7edf0399a800350ee /target/linux/mediatek
parent9bac24e767611375a261a0ae9b0ec055eeec86dd (diff)
downloadupstream-3555a2930f9ccefaabe4400364e1e2b29692b5de.tar.gz
upstream-3555a2930f9ccefaabe4400364e1e2b29692b5de.tar.bz2
upstream-3555a2930f9ccefaabe4400364e1e2b29692b5de.zip
treewide: fix shell errors during dump stage
Fixes following issues: bash: -c: line 1: `echo 1686820180<LINUX_VERMAGIC> | /staging_dir/host/bin/mkhash md5 | cut -b1-8' bash: -c: line 1: `echo 1686820180<LINUX_VERMAGIC> | /staging_dir/host/bin/mkhash md5 | sed -E 's/(.{8})(.{4})(.{4})(.{4})(.{10})../\1-\2-\3-\4-\500/'' bash: -c: line 1: syntax error near unexpected token `|' bash: line 1: *1024*1024: syntax error: operand expected (error token is "*1024*1024") bash: line 1: (64 + ): syntax error: operand expected (error token is ")") expr: syntax error: missing argument after '+' Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit 8fc496be860192f8bd1f16913657626014c8863f) [ fix merge conflicts, adapt to 22.03 ] Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'target/linux/mediatek')
-rw-r--r--target/linux/mediatek/image/mt7622.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index e741c46926..b0611bd17c 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -97,7 +97,9 @@ define Device/bananapi_bpi-r64
$(if $(CONFIG_TARGET_ROOTFS_SQUASHFS),\
pad-to 46080k | append-image squashfs-sysupgrade.itb | check-size | gzip \
)
+ifeq ($(DUMP),)
IMAGE_SIZE := $$(shell expr 45 + $$(CONFIG_TARGET_ROOTFS_PARTSIZE))m
+endif
KERNEL := kernel-bin | gzip
KERNEL_INITRAMFS := kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb with-initrd | pad-to 128k
IMAGE/sysupgrade.itb := append-kernel | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb external-static-with-rootfs | append-metadata