aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2020-05-04 16:28:11 +0200
committerJohn Crispin <john@phrozen.org>2020-05-04 16:28:46 +0200
commit220f43e0f2a0870305d40add4c3314edf150f9be (patch)
tree810265a0f2821357c6d5c94373f53fa689100067 /target/linux/mediatek
parentabb0452cd8ec4e7d131d9728e5dd3b613dd10bbb (diff)
downloadupstream-220f43e0f2a0870305d40add4c3314edf150f9be.tar.gz
upstream-220f43e0f2a0870305d40add4c3314edf150f9be.tar.bz2
upstream-220f43e0f2a0870305d40add4c3314edf150f9be.zip
mediatek: fix image building
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/mediatek')
-rw-r--r--target/linux/mediatek/image/Makefile26
-rw-r--r--target/linux/mediatek/image/mt7622.mk2
-rw-r--r--target/linux/mediatek/image/mt7623.mk2
-rw-r--r--target/linux/mediatek/image/mt7629.mk2
4 files changed, 8 insertions, 24 deletions
diff --git a/target/linux/mediatek/image/Makefile b/target/linux/mediatek/image/Makefile
index ddf4e435c7..385277fd3d 100644
--- a/target/linux/mediatek/image/Makefile
+++ b/target/linux/mediatek/image/Makefile
@@ -8,18 +8,6 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-# for arm
-KERNEL_LOADADDR := 0x80008000
-
-# for arm64
-ifeq ($(SUBTARGET),mt7622)
-KERNEL_LOADADDR = 0x41080000
-endif
-
-ifeq ($(SUBTARGET),mt7629)
-KERNEL_LOADADDR = 0x40008000
-endif
-
define Build/sysupgrade-emmc
rm -f $@.recovery
mkfs.fat -C $@.recovery 3070
@@ -37,7 +25,7 @@ define Device/Default
FILESYSTEMS := squashfs
DEVICE_DTS_DIR := $(DTS_DIR)
IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+ IMAGE/sysupgrade.bin := append-kernel | pad-to 128k | append-rootfs | pad-rootfs | append-metadata
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
ifeq ($(SUBTARGET),mt7623)
KERNEL_NAME := zImage
@@ -50,17 +38,7 @@ else
endif
endef
-ifeq ($(SUBTARGET),mt7622)
-include mt7622.mk
-endif
-
-ifeq ($(SUBTARGET),mt7623)
-include mt7623.mk
-endif
-
-ifeq ($(SUBTARGET),mt7629)
-include mt7629.mk
-endif
+include $(SUBTARGET).mk
define Image/Build
$(call Image/Build/$(1),$(1))
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index 1d44539a71..a386bf1ee2 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -1,3 +1,5 @@
+KERNEL_LOADADDR := 0x41080000
+
define Device/mediatek_mt7622-rfb1
DEVICE_VENDOR := MediaTek
DEVICE_MODEL := MTK7622 rfb1 AP
diff --git a/target/linux/mediatek/image/mt7623.mk b/target/linux/mediatek/image/mt7623.mk
index 4c3c927439..a4a9fff2b7 100644
--- a/target/linux/mediatek/image/mt7623.mk
+++ b/target/linux/mediatek/image/mt7623.mk
@@ -1,3 +1,5 @@
+KERNEL_LOADADDR := 0x80008000
+
define Device/unielec_u7623-02-emmc-512m
DEVICE_VENDOR := UniElec
DEVICE_MODEL := U7623-02
diff --git a/target/linux/mediatek/image/mt7629.mk b/target/linux/mediatek/image/mt7629.mk
index ef4b752351..754ce974b1 100644
--- a/target/linux/mediatek/image/mt7629.mk
+++ b/target/linux/mediatek/image/mt7629.mk
@@ -1,3 +1,5 @@
+KERNEL_LOADADDR := 0x40008000
+
define Device/mediatek_mt7629-rfb
DEVICE_VENDOR := MediaTek
DEVICE_MODEL := MT7629 rfb AP