aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/patches-4.19/0003-switch-add-mt7531.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2019-08-02 10:33:28 +0200
committerJohn Crispin <john@phrozen.org>2019-08-02 10:36:11 +0200
commit66458c49aa14ebc9ba2e4f9b6a323b8ff122807b (patch)
tree43cd8477d8341136c691d49b139038b14793f635 /target/linux/mediatek/patches-4.19/0003-switch-add-mt7531.patch
parentcb49e46a8a4526d86270ced3ba3aa90225ca82d7 (diff)
downloadupstream-66458c49aa14ebc9ba2e4f9b6a323b8ff122807b.tar.gz
upstream-66458c49aa14ebc9ba2e4f9b6a323b8ff122807b.tar.bz2
upstream-66458c49aa14ebc9ba2e4f9b6a323b8ff122807b.zip
mediatek: add v4.19 support
Bump the target to v4.19. Add a patch with additional eth driver fixes/features that MTK provided aswell as the driver for the new mt7530 switch. Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/mediatek/patches-4.19/0003-switch-add-mt7531.patch')
-rw-r--r--target/linux/mediatek/patches-4.19/0003-switch-add-mt7531.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/mediatek/patches-4.19/0003-switch-add-mt7531.patch b/target/linux/mediatek/patches-4.19/0003-switch-add-mt7531.patch
new file mode 100644
index 0000000000..65e56e4940
--- /dev/null
+++ b/target/linux/mediatek/patches-4.19/0003-switch-add-mt7531.patch
@@ -0,0 +1,23 @@
+Index: linux-4.19.57/drivers/net/phy/Kconfig
+===================================================================
+--- linux-4.19.57.orig/drivers/net/phy/Kconfig
++++ linux-4.19.57/drivers/net/phy/Kconfig
+@@ -292,6 +292,8 @@ config RTL8367B_PHY
+
+ endif # RTL8366_SMI
+
++source "drivers/net/phy/mtk/mt753x/Kconfig"
++
+ comment "MII PHY device drivers"
+
+ config SFP
+Index: linux-4.19.57/drivers/net/phy/Makefile
+===================================================================
+--- linux-4.19.57.orig/drivers/net/phy/Makefile
++++ linux-4.19.57/drivers/net/phy/Makefile
+@@ -100,3 +100,5 @@ obj-$(CONFIG_STE10XP) += ste10Xp.o
+ obj-$(CONFIG_TERANETICS_PHY) += teranetics.o
+ obj-$(CONFIG_VITESSE_PHY) += vitesse.o
+ obj-$(CONFIG_XILINX_GMII2RGMII) += xilinx_gmii2rgmii.o
++obj-$(CONFIG_MT753X_GSW) += mtk/mt753x/
++