aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/patches-4.19/0003-mt7531-gsw-internal_phy_calibration.patch
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-08-05 12:55:32 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-08-06 11:52:47 +0200
commit42d9bccadb4b5dcb1a598fb99867ede5499605c4 (patch)
tree2e1a932bb5e01da8b71691824a6eb38d77747200 /target/linux/mediatek/patches-4.19/0003-mt7531-gsw-internal_phy_calibration.patch
parent96f1d4b02b29fa6153dfa96a8672af97b139cbbc (diff)
downloadupstream-42d9bccadb4b5dcb1a598fb99867ede5499605c4.tar.gz
upstream-42d9bccadb4b5dcb1a598fb99867ede5499605c4.tar.bz2
upstream-42d9bccadb4b5dcb1a598fb99867ede5499605c4.zip
kernel: bump 4.19 to 4.19.64
Refreshed all patches. Remove upstreamed: - 100-powerpc-4xx-uic-clear-pending-interrupt-after-irq-ty.patch - 950-0309-usb-dwc2-Disable-all-EP-s-on-disconnect.patch - 950-0310-usb-dwc2-Fix-disable-all-EP-s-on-disconnect.patch Fixes: - CVE-2019-13648 - CVE-2019-3900 - CVE-2019-10207 Compile-tested on: cns3xxx Runtime-tested on: cns3xxx Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/mediatek/patches-4.19/0003-mt7531-gsw-internal_phy_calibration.patch')
-rw-r--r--target/linux/mediatek/patches-4.19/0003-mt7531-gsw-internal_phy_calibration.patch11
1 files changed, 4 insertions, 7 deletions
diff --git a/target/linux/mediatek/patches-4.19/0003-mt7531-gsw-internal_phy_calibration.patch b/target/linux/mediatek/patches-4.19/0003-mt7531-gsw-internal_phy_calibration.patch
index 7ade515a7f..8e4ef2ae1b 100644
--- a/target/linux/mediatek/patches-4.19/0003-mt7531-gsw-internal_phy_calibration.patch
+++ b/target/linux/mediatek/patches-4.19/0003-mt7531-gsw-internal_phy_calibration.patch
@@ -1,16 +1,15 @@
--- a/drivers/net/phy/mtk/mt753x/Makefile
+++ b/drivers/net/phy/mtk/mt753x/Makefile
-@@ -5,6 +5,6 @@
- obj-$(CONFIG_MT753X_GSW) += mt753x.o
+@@ -7,5 +7,5 @@ obj-$(CONFIG_MT753X_GSW) += mt753x.o
+ mt753x-$(CONFIG_SWCONFIG) += mt753x_swconfig.o
mt753x-y += mt753x_mdio.o mt7530.o mt7531.o \
- mt753x_common.o mt753x_nl.o
+ mt753x_common.o mt753x_nl.o mt753x_phy.o
-
--- a/drivers/net/phy/mtk/mt753x/mt7531.c
+++ b/drivers/net/phy/mtk/mt753x/mt7531.c
-@@ -454,6 +454,18 @@ static void mt7531_core_pll_setup(struct gsw_mt753x *gsw)
+@@ -582,6 +582,18 @@ static void mt7531_core_pll_setup(struct
static int mt7531_internal_phy_calibration(struct gsw_mt753x *gsw)
{
@@ -31,7 +30,7 @@
--- a/drivers/net/phy/mtk/mt753x/mt753x.h
+++ b/drivers/net/phy/mtk/mt753x/mt753x.h
-@@ -141,6 +141,8 @@ void mt753x_mmd_ind_write(struct gsw_mt753x *gsw, int addr, int devad, u16 reg,
+@@ -147,6 +147,8 @@ void mt753x_mmd_ind_write(struct gsw_mt7
void mt753x_irq_worker(struct work_struct *work);
void mt753x_irq_enable(struct gsw_mt753x *gsw);
@@ -990,8 +989,6 @@
+
+ return ret;
+}
-diff --git a/target/linux/generic/files/drivers/net/phy/mtk/mt753x/mt753x_phy.h b/target/linux/generic/files/drivers/net/phy/mtk/mt753x/mt753x_phy.h
-new file mode 100755
--- /dev/null
+++ b/drivers/net/phy/mtk/mt753x/mt753x_phy.h
@@ -0,0 +1,145 @@