aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2021-04-23 18:32:11 +0900
committerDaniel Golle <daniel@makrotopia.org>2022-05-21 22:27:01 +0100
commit58b3b557b629f6a2046414e0e1b39189d918133f (patch)
treef87ed3c4b85f06c01946915a5343aa622ec69cd8 /target/linux/mediatek/image
parente01b1c22dfb669abb0ad14c83ec9b3e35ff3d15c (diff)
downloadupstream-58b3b557b629f6a2046414e0e1b39189d918133f.tar.gz
upstream-58b3b557b629f6a2046414e0e1b39189d918133f.tar.bz2
upstream-58b3b557b629f6a2046414e0e1b39189d918133f.zip
mediatek: mt7622: add support for ELECOM WRC-X3200GST3
ELECOM WRC-X3200GST3 is a 2.4/5 GHz band 11ax (Wi-Fi 6) router, based on MT7622B. Specifications: - SoC : MediaTek MT7622B - RAM : DDR3 512 MiB (Nanya NT5CC256M16ER-EK) - Flash : SPI-NAND 128 MiB (Winbond W25N01GVZEIG) - WLAN : 2.4/5 GHz 4T4R - 2.4 GHz : MediaTek MT7622B (SoC) - 5 GHz : MediaTek MT7915A - Ethernet : 5x 10/100/1000 Mbps - Switch : MediaTek MT7531 - LEDs/Keys : 6x/4x (2x buttons, 1x slide-switch) - UART : through-hole on PCB - J19: 3.3V, GND, TX, RX from power jack side - 115200n8 - Power : 12 VDC, 1.5 A Flash instruction using factory image: 1. Boot WRC-X3200GST3 normally with "Router" mode 2. Access to "http://192.168.2.1/" and open firmware update page ("ファームウェア更新") 3. Select the OpenWrt factory image and click apply ("適用") button 4. Wait ~120 seconds to complete flashing MAC Addresses: LAN : 04:AB:18:xx:xx:77 (Factory, 0x7FFF4 (hex)) WAN : 04:AB:18:xx:xx:78 (Factory, 0x7FFFA (hex)) 2.4 GHz: 04:AB:18:xx:xx:79 (Factory, 0x4 (hex)) 5 GHz : 04:AB:18:xx:xx:7A (none) Note: - currently, there is no "phy1tpt" trigger for 5 GHz wlan (MT7915) in "trigger" file of LEDs, use "phy1radio" trigger instead Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/mediatek/image')
-rw-r--r--target/linux/mediatek/image/mt7622.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index 39bc7bc2ea..aba8bdfe0b 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -137,6 +137,26 @@ define Device/elecom_wrc-2533gent
endef
TARGET_DEVICES += elecom_wrc-2533gent
+define Device/elecom_wrc-x3200gst3
+ DEVICE_VENDOR := ELECOM
+ DEVICE_MODEL := WRC-X3200GST3
+ DEVICE_DTS := mt7622-elecom-wrc-x3200gst3
+ DEVICE_DTS_DIR := ../dts
+ IMAGE_SIZE := 25600k
+ KERNEL_SIZE := 6144k
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ UBINIZE_OPTS := -E 5
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | pad-to $$(KERNEL_SIZE) | \
+ append-ubi | check-size | \
+ elecom-wrc-gs-factory WRC-X3200GST3 0.00 -N | \
+ append-string MT7622_ELECOM_WRC-X3200GST3
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ DEVICE_PACKAGES := kmod-mt7915e
+endef
+TARGET_DEVICES += elecom_wrc-x3200gst3
+
define Device/linksys_e8450
DEVICE_VENDOR := Linksys
DEVICE_MODEL := E8450