aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/mt7622.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2020-06-04 14:26:11 +0200
committerJohn Crispin <john@phrozen.org>2020-06-07 17:53:37 +0200
commitf72a2b004c3541b1834fe7af2ae69dcfcde8d338 (patch)
tree84a9d0d9341db4db44b1829a721525aa5d3cfc80 /target/linux/mediatek/image/mt7622.mk
parent55b97b688541b050e6d9f3f87c124c06fabe24ed (diff)
downloadupstream-f72a2b004c3541b1834fe7af2ae69dcfcde8d338.tar.gz
upstream-f72a2b004c3541b1834fe7af2ae69dcfcde8d338.tar.bz2
upstream-f72a2b004c3541b1834fe7af2ae69dcfcde8d338.zip
mediatek: add bpi-r64 emmc support
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/mediatek/image/mt7622.mk')
-rw-r--r--target/linux/mediatek/image/mt7622.mk14
1 files changed, 13 insertions, 1 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index bb7d89a826..d9ddb0755e 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -10,7 +10,19 @@ define Device/bpi_bananapi-r64
endef
TARGET_DEVICES += bpi_bananapi-r64
-define Device/elecom_wrc-2533gent
+define Device/bpi_bananapi-r64-rootdisk
+ DEVICE_VENDOR := Bpi
+ DEVICE_MODEL := Banana Pi R64 (rootdisk)
+ DEVICE_DTS := mt7622-bananapi-bpi-r64-rootdisk
+ DEVICE_DTS_DIR := $(DTS_DIR)/mediatek
+ SUPPORTED_DEVICES := bananapi,bpi-r64
+ DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3 kmod-ata-ahci-mtk
+ IMAGES := sysupgrade-emmc.bin.gz
+ IMAGE/sysupgrade-emmc.bin.gz := sysupgrade-emmc | gzip | append-metadata
+endef
+TARGET_DEVICES += bpi_bananapi-r64-rootdisk
+
+define Device/elecom-wrc-2533gent
DEVICE_VENDOR := Elecom
DEVICE_MODEL := WRC-2533GENT
DEVICE_DTS := mt7622-elecom-wrc-2533gent