aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/mt7622.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2020-03-27 16:13:06 +0100
committerJohn Crispin <john@phrozen.org>2020-03-27 16:18:57 +0100
commit3a8dbcf5c2f3c71240365006f8dae13f79f729b1 (patch)
tree9fd9f965a4de2adbdd0da11fbada8b7c4aaeb7be /target/linux/mediatek/image/mt7622.mk
parentd3f058db1cb9b2d43764cd0d84fdc2779f0abacf (diff)
downloadupstream-3a8dbcf5c2f3c71240365006f8dae13f79f729b1.tar.gz
upstream-3a8dbcf5c2f3c71240365006f8dae13f79f729b1.tar.bz2
upstream-3a8dbcf5c2f3c71240365006f8dae13f79f729b1.zip
mediatke: add support for elecom-wrc-2533gent
This commit adds support for the MT7622-based Elecom WRC-2533gent router, with spi-nand storage and 512MB RAM. The device has the following specifications: * MT7622 (arm64 dual-core) * 512MB RAM (DDR3) * 4GB storage (spi-nand) * 5x 1Gbps Ethernet (RTL8337C switch) * 1x UART header * 1x USB 3.0 port * 5x LEDs * 1x reset button * 1x WPS button * 1x slider switch * 1x DC jack for main power (12V) The following has been tested and is working: * Ethernet switch * 2.4g and 5g wifi * USB 3.0 port * sysupgrade * buttons/leds Not working: * bluetooth firmware does not load even though it is present int he rootfs Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/mediatek/image/mt7622.mk')
-rw-r--r--target/linux/mediatek/image/mt7622.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index 0d8af5a9ee..0aea5dc488 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -16,3 +16,14 @@ define Device/bpi_bananapi-r64
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3 kmod-ata-ahci-mtk
endef
TARGET_DEVICES += bpi_bananapi-r64
+
+define Device/elecom-wrc-2533gent
+ DEVICE_VENDOR := Elecom
+ DEVICE_MODEL := Elecom WRC-2533GENT
+ DEVICE_DTS := mt7622-elecom-wrc-2533gent
+ DEVICE_DTS_DIR := $(DTS_DIR)/mediatek
+ DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3 \
+ kmod-mt7615e mt7622bt-firmware swconfig
+ SUPPORTED_DEVICES := elecom,wrc-2533gent
+endef
+TARGET_DEVICES += elecom-wrc-2533gent