aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/patches-3.18/008-mcs814x_gpio.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2018-05-24 17:23:41 +0200
committerJohn Crispin <john@phrozen.org>2018-05-24 17:24:31 +0200
commitfa0275bd90ce913de57330c9abbe594703d589c6 (patch)
treef9864b2862c06f8302774e817b587644e66d6da9 /target/linux/mcs814x/patches-3.18/008-mcs814x_gpio.patch
parent76ba98d9b0b6e06bb7e843207654223cb62518d6 (diff)
downloadupstream-fa0275bd90ce913de57330c9abbe594703d589c6.tar.gz
upstream-fa0275bd90ce913de57330c9abbe594703d589c6.tar.bz2
upstream-fa0275bd90ce913de57330c9abbe594703d589c6.zip
target/linux: drop anything not on v4.9 or v4.14
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/mcs814x/patches-3.18/008-mcs814x_gpio.patch')
-rw-r--r--target/linux/mcs814x/patches-3.18/008-mcs814x_gpio.patch25
1 files changed, 0 insertions, 25 deletions
diff --git a/target/linux/mcs814x/patches-3.18/008-mcs814x_gpio.patch b/target/linux/mcs814x/patches-3.18/008-mcs814x_gpio.patch
deleted file mode 100644
index f0944bffd3..0000000000
--- a/target/linux/mcs814x/patches-3.18/008-mcs814x_gpio.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/drivers/gpio/Kconfig
-+++ b/drivers/gpio/Kconfig
-@@ -820,6 +820,12 @@ config GPIO_MC33880
- SPI driver for Freescale MC33880 high-side/low-side switch.
- This provides GPIO interface supporting inputs and outputs.
-
-+config GPIO_MCS814X
-+ tristate "Moschip MCS814x GPIO support"
-+ depends on ARCH_MCS814X
-+ help
-+ GPIO driver for Moschip MCS814x SoC gpio controllers.
-+
- config GPIO_74X164
- tristate "74x164 serial-in/parallel-out 8-bits shift register"
- depends on SPI_MASTER && OF
---- a/drivers/gpio/Makefile
-+++ b/drivers/gpio/Makefile
-@@ -49,6 +49,7 @@ obj-$(CONFIG_GPIO_MAX732X) += gpio-max73
- obj-$(CONFIG_GPIO_MC33880) += gpio-mc33880.o
- obj-$(CONFIG_GPIO_MC9S08DZ60) += gpio-mc9s08dz60.o
- obj-$(CONFIG_GPIO_MCP23S08) += gpio-mcp23s08.o
-+obj-$(CONFIG_GPIO_MCS814X) += gpio-mcs814x.o
- obj-$(CONFIG_GPIO_ML_IOH) += gpio-ml-ioh.o
- obj-$(CONFIG_GPIO_MM_LANTIQ) += gpio-mm-lantiq.o
- obj-$(CONFIG_GPIO_MOXART) += gpio-moxart.o