aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/modules.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-06-19 14:48:56 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-06-19 14:48:56 +0000
commitf4afa00862b7db8a2da8c012843a286716c0a534 (patch)
tree9c15efab8fd398654de98648e07f26c51d6eec66 /target/linux/mcs814x/modules.mk
parent7c87391c55a713a9ef9df169ab23e79177184b1a (diff)
downloadupstream-f4afa00862b7db8a2da8c012843a286716c0a534.tar.gz
upstream-f4afa00862b7db8a2da8c012843a286716c0a534.tar.bz2
upstream-f4afa00862b7db8a2da8c012843a286716c0a534.zip
add Moschip MSC814x support
This target currently only supports Moschip's MCS8140 SoC, but support for other chips in the same family (MCS8142, MCS8144) will be easy to add. Target support is entirely using Device Tree for probing peripherals. Drivers support include: - PCI - USB 1 & 2 - watchdog - random number generator - UART - timer - internal Ethernet PHY - Ethernet MAC core Support for the following boards is included using Device Tree - Devolo dLAN USB Extender - Tigal RBT-832 SVN-Revision: 32462
Diffstat (limited to 'target/linux/mcs814x/modules.mk')
-rw-r--r--target/linux/mcs814x/modules.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/mcs814x/modules.mk b/target/linux/mcs814x/modules.mk
new file mode 100644
index 0000000000..c29ca860d1
--- /dev/null
+++ b/target/linux/mcs814x/modules.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+define KernelPackage/mcs814x-wdt
+ SUBMENU:=$(OTHER_MENU)
+ DEPENDS:=@TARGET_mcs814x
+ TITLE:=MCS814x watchdog driver
+ KCONFIG:=CONFIG_MCS814X_WATCHDOG
+ FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/mcs814x_wdt.ko
+ AUTOLOAD:=$(call AutoLoad,50,mcs814x_wdt)
+endef
+
+define KernelPackage/mcs814x-wdt/description
+ Kernel module for the Moschip MCS814x watchdog timer.
+endef
+
+$(eval $(call KernelPackage,mcs814x-wdt))