aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-09-03 20:25:40 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-09-03 20:25:40 +0000
commitc5fa46dc5f0cc9f973c75f20e6b20848ddc898c4 (patch)
tree5dc17e5582482b7bd28000bb05fed8966646be2b /target/linux/mcs814x/image
parenta7b6531eea8816a1987e5fcb0e2c0c9c32a12680 (diff)
downloadupstream-c5fa46dc5f0cc9f973c75f20e6b20848ddc898c4.tar.gz
upstream-c5fa46dc5f0cc9f973c75f20e6b20848ddc898c4.tar.bz2
upstream-c5fa46dc5f0cc9f973c75f20e6b20848ddc898c4.zip
[mcs814x] add Generic and dLAN USB Extender profiles
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33313 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mcs814x/image')
-rw-r--r--target/linux/mcs814x/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/mcs814x/image/Makefile b/target/linux/mcs814x/image/Makefile
index 88c7af3a2a..5545e042e6 100644
--- a/target/linux/mcs814x/image/Makefile
+++ b/target/linux/mcs814x/image/Makefile
@@ -34,7 +34,7 @@ define Image/Prepare
cp $(LINUX_DIR)/arch/$(ARCH)/boot/zImage $(KDIR)/zImage
endef
-define Image/Build/dlan
+define Image/Build/Profile/dLAN_USB_Extender
dd if=$(KDIR)/uImage-dlan-usb-extender bs=1M conv=sync of=$(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
cat $(KDIR)/root.$(1) >> $(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
cp $(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin $(BIN_DIR)/
@@ -46,9 +46,9 @@ define Image/BuildKernel
endef
define Image/Build
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
$(call Image/Build/$(1))
- $(call Image/Build/dlan,$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+ $(call Image/Build/Profile/$(PROFILE),$(1))
endef
$(eval $(call BuildImage))