aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/malta
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-03-28 14:34:26 +0000
committerPetr Štetiar <ynezz@true.cz>2019-06-25 14:12:22 +0000
commit22c4d0c311b07766101234eae7416183dea8f01b (patch)
tree69f45b49463f2a59b62b8b0eeff09bfbf6e1b309 /target/linux/malta
parentf965f3a5496bef94d29ece2da4de10bd5ac344b7 (diff)
downloadupstream-22c4d0c311b07766101234eae7416183dea8f01b.tar.gz
upstream-22c4d0c311b07766101234eae7416183dea8f01b.tar.bz2
upstream-22c4d0c311b07766101234eae7416183dea8f01b.zip
malta: fix overlay support by updating to f2fs/ext4 based overlays
Current snapshot images doesn't provide images with usable overlay filesystems: mount_root: no usable overlay filesystem found, using tmpfs overlay So this patch fixes this by updating support to current f2fs/ext4 based overlays and providing squashfs with proper rootfs TARGET_ROOTFS_PARTSIZE size. While at it, I've also added support for optional gzipping of the images, and renamed the output rootfs image filenames to match the more common naming pattern $(IMG_PREFIX)-rootfs-$(FS-TYPE).img. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/malta')
-rw-r--r--target/linux/malta/Makefile4
-rw-r--r--target/linux/malta/image/Makefile13
2 files changed, 10 insertions, 7 deletions
diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
index 435c1b6568..6d520e4a52 100644
--- a/target/linux/malta/Makefile
+++ b/target/linux/malta/Makefile
@@ -12,12 +12,12 @@ CPU_TYPE:=24kc
SUBTARGETS:=le be le64 be64
INITRAMFS_EXTRA_FILES:=
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-FEATURES:=ramdisk
+FEATURES:=cpiogz ext4 ramdisk squashfs targz
KERNEL_PATCHVER:=4.19
include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += wpad-basic kmod-mac80211-hwsim kmod-pcnet32
+DEFAULT_PACKAGES += wpad-basic kmod-mac80211-hwsim kmod-pcnet32 mkf2fs e2fsprogs
$(eval $(call BuildTarget))
diff --git a/target/linux/malta/image/Makefile b/target/linux/malta/image/Makefile
index d49d4a762d..72e7eab807 100644
--- a/target/linux/malta/image/Makefile
+++ b/target/linux/malta/image/Makefile
@@ -34,18 +34,21 @@ define Image/BuildKernel
cp $(KDIR)/uImage.gz $(BIN_DIR)/$(IMG_PREFIX)-uImage-gzip
endef
-define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
-endef
-
define Image/Build/Initramfs
cp $(KDIR)/vmlinux-initramfs.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs.elf
cp $(KDIR)/vmlinux-initramfs $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs.bin
endef
+define Image/Build/gzip
+ gzip -f9n $(BIN_DIR)/$(IMG_ROOTFS)-$(1).img
+endef
+
+$(eval $(call Image/gzip-ext4-padded-squashfs))
+
define Image/Build
$(call Image/Build/$(1))
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+ $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_ROOTFS)-$(1).img
+ $(call Image/Build/gzip/$(1))
endef
$(eval $(call BuildImage))