aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/leon/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-01-27 12:51:25 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-01-27 12:51:25 +0000
commit0f325459eae511f5f413b4e12af576214a30320c (patch)
tree682d14f882b81b6e936d4528cca719397b4f0164 /target/linux/leon/Makefile
parenta361eab890a4c5143d556e08d7e775c5175bad86 (diff)
downloadupstream-0f325459eae511f5f413b4e12af576214a30320c.tar.gz
upstream-0f325459eae511f5f413b4e12af576214a30320c.tar.bz2
upstream-0f325459eae511f5f413b4e12af576214a30320c.zip
add preliminary LEON support
SVN-Revision: 25139
Diffstat (limited to 'target/linux/leon/Makefile')
-rw-r--r--target/linux/leon/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/leon/Makefile b/target/linux/leon/Makefile
new file mode 100644
index 0000000000..eb3b83fcfe
--- /dev/null
+++ b/target/linux/leon/Makefile
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=sparc
+BOARD:=leon
+BOARDNAME:=LEON
+FEATURES+=fpu tgz
+
+CFLAGS:=-Os -pipe -mcpu=v8 -funit-at-a-time
+KERNELNAME:="uImage"
+
+LINUX_VERSION:=2.6.36.2
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))