aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-19 20:05:35 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-23 12:45:21 +0100
commitf52081bcf938efcd910832f3c3713ab9f3ca0738 (patch)
tree58cbf57000a46307d000c606c970e53e03b1a9e4 /target/linux/layerscape
parentb2bab951166ab30717b345b95b0dc8d6999ba16e (diff)
downloadupstream-f52081bcf938efcd910832f3c3713ab9f3ca0738.tar.gz
upstream-f52081bcf938efcd910832f3c3713ab9f3ca0738.tar.bz2
upstream-f52081bcf938efcd910832f3c3713ab9f3ca0738.zip
treewide: provide global default for SUPPORTED_DEVICES
The majority of our targets provide a default value for the variable SUPPORTED_DEVICES, which is used in images to check against the compatible on a running device: SUPPORTED_DEVICES := $(subst _,$(comma),$(1)) At the moment, this is implemented in the Device/Default block of the individual targets or even subtargets. However, since we standardized device names and compatible in the recent past, almost all targets are following the same scheme now: device/image name: vendor_model compatible: vendor,model The equal redundant definitions are a symptom of this process. Consequently, this patch moves the definition to image.mk making it a global default. For the few targets not using the scheme above, SUPPORTED_DEVICES will be defined to a different value in Device/Default anyway, overwriting the default. In other words: This change is supposed to be cosmetic. This can be used as a global measure to get the current compatible with: $(firstword $(SUPPORTED_DEVICES)) (Though this is not precisely an achievement of this commit.) Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/layerscape')
-rw-r--r--target/linux/layerscape/image/armv7.mk1
-rw-r--r--target/linux/layerscape/image/armv8_64b.mk1
2 files changed, 0 insertions, 2 deletions
diff --git a/target/linux/layerscape/image/armv7.mk b/target/linux/layerscape/image/armv7.mk
index 08ef6cb9a1..62921a5ef9 100644
--- a/target/linux/layerscape/image/armv7.mk
+++ b/target/linux/layerscape/image/armv7.mk
@@ -15,7 +15,6 @@ define Device/Default
KERNEL_LOADADDR := 0x80008000
KERNEL_ENTRY_POINT := 0x80008000
DEVICE_DTS = $(lastword $(subst _, ,$(1)))
- SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
IMAGE_SIZE := 64m
IMAGE/sysupgrade.bin = \
ls-append-dtb $$(DEVICE_DTS) | pad-to 1M | \
diff --git a/target/linux/layerscape/image/armv8_64b.mk b/target/linux/layerscape/image/armv8_64b.mk
index 264f7dfd84..a3f4428299 100644
--- a/target/linux/layerscape/image/armv8_64b.mk
+++ b/target/linux/layerscape/image/armv8_64b.mk
@@ -14,7 +14,6 @@ define Device/Default
KERNEL_LOADADDR := 0x80080000
KERNEL_ENTRY_POINT := 0x80080000
DEVICE_DTS = freescale/$(subst _,-,$(1))
- SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
IMAGE_SIZE := 64m
IMAGE/sysupgrade.bin = \
ls-append-dtb $$(DEVICE_DTS) | pad-to 1M | \