aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/patches-5.4/701-net-0262-net-dsa-ocelot-add-tagger-for-Ocelot-Felix-switches.patch
diff options
context:
space:
mode:
authorJohn Audia <graysky@archlinux.us>2020-08-26 06:29:39 -0400
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-30 19:44:47 +0200
commit05b8e84362b8455dec6db9b862826f21e8f24341 (patch)
treefc8ec494e6ca0531225d94be7346713d91e65893 /target/linux/layerscape/patches-5.4/701-net-0262-net-dsa-ocelot-add-tagger-for-Ocelot-Felix-switches.patch
parentf589bd9283457f0bfddfeb2af468a413a3802b9b (diff)
downloadupstream-05b8e84362b8455dec6db9b862826f21e8f24341.tar.gz
upstream-05b8e84362b8455dec6db9b862826f21e8f24341.tar.bz2
upstream-05b8e84362b8455dec6db9b862826f21e8f24341.zip
kernel: bump 5.4 to 5.4.61
Manually merged: backport-5.4 011-kbuild-export-SUBARCH.patch layerscape 701-net-0262-net-dsa-ocelot-add-tagger-for-Ocelot-Felix-switches.patch All other modifications made by update_kernel.sh Build-tested: x86/64, lantiq/xrx200, ramips/mt7621 Run-tested: ipq806x (R7800), lantiq/xrx200, x86/64, ramips (RT-AC57U) No dmesg regressions, everything functional Signed-off-by: John Audia <graysky@archlinux.us> [minor commit message adjustments] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/layerscape/patches-5.4/701-net-0262-net-dsa-ocelot-add-tagger-for-Ocelot-Felix-switches.patch')
-rw-r--r--target/linux/layerscape/patches-5.4/701-net-0262-net-dsa-ocelot-add-tagger-for-Ocelot-Felix-switches.patch18
1 files changed, 9 insertions, 9 deletions
diff --git a/target/linux/layerscape/patches-5.4/701-net-0262-net-dsa-ocelot-add-tagger-for-Ocelot-Felix-switches.patch b/target/linux/layerscape/patches-5.4/701-net-0262-net-dsa-ocelot-add-tagger-for-Ocelot-Felix-switches.patch
index 38d9e0b5bd..b849387c44 100644
--- a/target/linux/layerscape/patches-5.4/701-net-0262-net-dsa-ocelot-add-tagger-for-Ocelot-Felix-switches.patch
+++ b/target/linux/layerscape/patches-5.4/701-net-0262-net-dsa-ocelot-add-tagger-for-Ocelot-Felix-switches.patch
@@ -39,7 +39,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
--- a/MAINTAINERS
+++ b/MAINTAINERS
-@@ -17354,6 +17354,13 @@ S: Maintained
+@@ -17355,6 +17355,13 @@ S: Maintained
F: drivers/input/serio/userio.c
F: include/uapi/linux/userio.h
@@ -60,22 +60,22 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
#define DSA_TAG_PROTO_SJA1105_VALUE 13
#define DSA_TAG_PROTO_KSZ8795_VALUE 14
+#define DSA_TAG_PROTO_OCELOT_VALUE 15
+ #define DSA_TAG_PROTO_RTL4_A_VALUE 17
enum dsa_tag_protocol {
- DSA_TAG_PROTO_NONE = DSA_TAG_PROTO_NONE_VALUE,
-@@ -59,6 +60,7 @@ enum dsa_tag_protocol {
+@@ -60,6 +61,7 @@ enum dsa_tag_protocol {
DSA_TAG_PROTO_8021Q = DSA_TAG_PROTO_8021Q_VALUE,
DSA_TAG_PROTO_SJA1105 = DSA_TAG_PROTO_SJA1105_VALUE,
DSA_TAG_PROTO_KSZ8795 = DSA_TAG_PROTO_KSZ8795_VALUE,
+ DSA_TAG_PROTO_OCELOT = DSA_TAG_PROTO_OCELOT_VALUE,
+ DSA_TAG_PROTO_RTL4_A = DSA_TAG_PROTO_RTL4_A_VALUE,
};
- struct packet_type;
--- a/net/dsa/Kconfig
+++ b/net/dsa/Kconfig
-@@ -80,6 +80,13 @@ config NET_DSA_TAG_KSZ
- Say Y if you want to enable support for tagging frames for the
- Microchip 8795/9477/9893 families of switches.
+@@ -87,6 +87,13 @@ config NET_DSA_TAG_RTL4_A
+ Realtek switches with 4 byte protocol A tags, sich as found in
+ the Realtek RTL8366RB.
+config NET_DSA_TAG_OCELOT
+ tristate "Tag driver for Ocelot family of switches"
@@ -89,8 +89,8 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
help
--- a/net/dsa/Makefile
+++ b/net/dsa/Makefile
-@@ -12,6 +12,7 @@ obj-$(CONFIG_NET_DSA_TAG_GSWIP) += tag_g
- obj-$(CONFIG_NET_DSA_TAG_KSZ) += tag_ksz.o
+@@ -13,6 +13,7 @@ obj-$(CONFIG_NET_DSA_TAG_KSZ) += tag_ksz
+ obj-$(CONFIG_NET_DSA_TAG_RTL4_A) += tag_rtl4_a.o
obj-$(CONFIG_NET_DSA_TAG_LAN9303) += tag_lan9303.o
obj-$(CONFIG_NET_DSA_TAG_MTK) += tag_mtk.o
+obj-$(CONFIG_NET_DSA_TAG_OCELOT) += tag_ocelot.o