aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/patches-5.4/303-core-0012-LF-789-1-Revert-scripts-Makefile-Enable-creation-of-.patch
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2020-04-10 10:47:05 +0800
committerPetr Štetiar <ynezz@true.cz>2020-05-07 12:53:06 +0200
commitcddd4591404fb4c53dc0b3c0b15b942cdbed4356 (patch)
tree392c1179de46b0f804e3789edca19069b64e6b44 /target/linux/layerscape/patches-5.4/303-core-0012-LF-789-1-Revert-scripts-Makefile-Enable-creation-of-.patch
parentd1d2c0b5579ea4f69a42246c9318539d61ba1999 (diff)
downloadupstream-cddd4591404fb4c53dc0b3c0b15b942cdbed4356.tar.gz
upstream-cddd4591404fb4c53dc0b3c0b15b942cdbed4356.tar.bz2
upstream-cddd4591404fb4c53dc0b3c0b15b942cdbed4356.zip
layerscape: add patches-5.4
Add patches for linux-5.4. The patches are from NXP LSDK-20.04 release which was tagged LSDK-20.04-V5.4. https://source.codeaurora.org/external/qoriq/qoriq-components/linux/ For boards LS1021A-IOT, and Traverse-LS1043 which are not involved in LSDK, port the dts patches from 4.14. The patches are sorted into the following categories: 301-arch-xxxx 302-dts-xxxx 303-core-xxxx 701-net-xxxx 801-audio-xxxx 802-can-xxxx 803-clock-xxxx 804-crypto-xxxx 805-display-xxxx 806-dma-xxxx 807-gpio-xxxx 808-i2c-xxxx 809-jailhouse-xxxx 810-keys-xxxx 811-kvm-xxxx 812-pcie-xxxx 813-pm-xxxx 814-qe-xxxx 815-sata-xxxx 816-sdhc-xxxx 817-spi-xxxx 818-thermal-xxxx 819-uart-xxxx 820-usb-xxxx 821-vfio-xxxx Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'target/linux/layerscape/patches-5.4/303-core-0012-LF-789-1-Revert-scripts-Makefile-Enable-creation-of-.patch')
-rw-r--r--target/linux/layerscape/patches-5.4/303-core-0012-LF-789-1-Revert-scripts-Makefile-Enable-creation-of-.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/target/linux/layerscape/patches-5.4/303-core-0012-LF-789-1-Revert-scripts-Makefile-Enable-creation-of-.patch b/target/linux/layerscape/patches-5.4/303-core-0012-LF-789-1-Revert-scripts-Makefile-Enable-creation-of-.patch
new file mode 100644
index 0000000000..744930c726
--- /dev/null
+++ b/target/linux/layerscape/patches-5.4/303-core-0012-LF-789-1-Revert-scripts-Makefile-Enable-creation-of-.patch
@@ -0,0 +1,58 @@
+From b13487a97b51a619b4e681a6091a1da9d6733058 Mon Sep 17 00:00:00 2001
+From: Jason Liu <jason.hui.liu@nxp.com>
+Date: Fri, 10 Jan 2020 11:38:05 +0800
+Subject: [PATCH] LF-789-1 Revert "scripts: Makefile: Enable creation of
+ _symbols_ DT node for overlays"
+
+This reverts commit 432071b7a106060fa4e451e10249cef021af0b7c.
+
+commit: 432071b7a106 scripts: Makefile: Enable creation of _symbols_ DT node for overlays
+changes the common Makefile and force creation of __symbols__ node on all platforms.
+
+This is not good and not acceptible under some cases due to this change will increase
+the final DTB size a lot and bring big impact for others who does not need creation
+of _symbols_ DT node for overlays.For example, on i.MX OP-TEE, the maxsize of DT is 1MB,
+this patch will break some of the i.MX6/i.MX7 boards to boot with OP-TEE enabled.
+
+BTW, community has the similar patch but rejected. The following post discuss about this:
+https://lore.kernel.org/patchwork/patch/821645/
+
+For specifc plaform/board which need the creation of _symbols_ DT node for overlays, user can
+define DTC_FLAGS_target either trough dtc build command line(#1) or with board specific Makefile(#2)
+
+For example:#1
+
+make DTC_FLAGS_fsl-ls1028a-qds=-@ freescale/fsl-ls1028a-qds.dtb
+
+For example:#2
+
+In arch/arm64/boot/dts/freescale/Makefile,
+
+ @@ -1,4 +1,7 @@
+ # SPDX-License-Identifier: GPL-2.0
+ +# required for overlay support
+ +#DTC_FLAGS_fsl-ls1028a-qds := -@
+ +
+
+Signed-off-by: Jason Liu <jason.hui.liu@nxp.com>
+Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
+Reviewed-by: Alex Marginean <alexandru.marginean@nxp.com>
+Tested-by: Alex Marginean <alexandru.marginean@nxp.com>
+[fix commit message]
+Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
+---
+ scripts/Makefile.lib | 3 ---
+ 1 file changed, 3 deletions(-)
+
+--- a/scripts/Makefile.lib
++++ b/scripts/Makefile.lib
+@@ -255,9 +255,6 @@ endif
+
+ DTC_FLAGS += $(DTC_FLAGS_$(basetarget))
+
+-# Enable creation of _symbols_ node for DT overlays
+-DTC_FLAGS += -@
+-
+ # Generate an assembly file to wrap the output of the device tree compiler
+ quiet_cmd_dt_S_dtb= DTB $@
+ cmd_dt_S_dtb= \