aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/image/armv7.mk
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2018-07-10 11:58:59 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2018-09-22 21:20:57 +0200
commitf0ec7bd27d206ea0eb9587e178ce0d7ddc006bce (patch)
treee5a732d69a332010950f3f800838c8a14390a60c /target/linux/layerscape/image/armv7.mk
parent0d95eb2cce62102a849e8c9552c30dfee3fe6189 (diff)
downloadupstream-f0ec7bd27d206ea0eb9587e178ce0d7ddc006bce.tar.gz
upstream-f0ec7bd27d206ea0eb9587e178ce0d7ddc006bce.tar.bz2
upstream-f0ec7bd27d206ea0eb9587e178ce0d7ddc006bce.zip
layerscape: add armv7 subtarget and ls1021atwr board support
The NXP TWR-LS1021A module is a development system based on the QorIQ LS1021A processor. - This feature-rich, high-performance processor module can be used standalone or as part of an assembled Tower System development platform. - Incorporating dual Arm Cortex-A7 cores running up to 1 GHz, the TWR-LS1021A delivers an outstanding level of performance. - The TWR-LS1021A offers HDMI, SATA3 and USB3 connectors as well as a complete Linux software developer's package. - The module provides a comprehensive level of security that includes support for secure boot, Trust Architecture and tamper detection in both standby and active power modes, safeguarding the device from manufacture to deployment. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'target/linux/layerscape/image/armv7.mk')
-rw-r--r--target/linux/layerscape/image/armv7.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/layerscape/image/armv7.mk b/target/linux/layerscape/image/armv7.mk
new file mode 100644
index 0000000000..59cc982017
--- /dev/null
+++ b/target/linux/layerscape/image/armv7.mk
@@ -0,0 +1,31 @@
+#
+# Copyright 2018 NXP
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Device/Default
+ PROFILES := Default
+ FILESYSTEMS := squashfs
+ IMAGES := firmware.bin
+ KERNEL := kernel-bin | uImage none
+ KERNEL_NAME := zImage
+ KERNEL_LOADADDR := 0x80008000
+ KERNEL_ENTRY_POINT := 0x80008000
+endef
+
+define Device/ls1021atwr
+ DEVICE_TITLE := LS1021ATWR
+ DEVICE_PACKAGES += layerscape-rcw-ls1021atwr
+ DEVICE_DTS := ls1021a-twr
+ IMAGE/firmware.bin := \
+ ls-clean | \
+ ls-append $(1)-rcw.bin | pad-to 1M | \
+ ls-append $(1)-uboot.bin | pad-to 3M | \
+ ls-append $(1)-uboot-env.bin | pad-to 15M | \
+ ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
+ append-kernel | pad-to 32M | \
+ append-rootfs | pad-rootfs | check-size 67108865
+endef
+TARGET_DEVICES += ls1021atwr