aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-4.9
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2017-05-15 13:11:05 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2017-05-21 21:51:22 +0200
commite842e16f4583edeedec24ffe79a0e495bb9c7bff (patch)
treefaabedbe0c6cf8c6774d0f921f9352851c8dbccc /target/linux/lantiq/patches-4.9
parent088e28772c504ad622ba909b0f6d2986910e7a97 (diff)
downloadupstream-e842e16f4583edeedec24ffe79a0e495bb9c7bff.tar.gz
upstream-e842e16f4583edeedec24ffe79a0e495bb9c7bff.tar.bz2
upstream-e842e16f4583edeedec24ffe79a0e495bb9c7bff.zip
kernel: update kernel 4.9 to 4.9.29
- Refresh all patches - Removed upstreamed - Adapted 1 Compile tested on: bcm53xx, cns3xxx, imx6, lantiq Run tested on: cns3xxx & imx6 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com> [update from 4.9.28 to 4.9.29] Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/lantiq/patches-4.9')
-rw-r--r--target/linux/lantiq/patches-4.9/0008-MIPS-lantiq-backport-old-timer-code.patch2
-rw-r--r--target/linux/lantiq/patches-4.9/0026-NET-multi-phy-support.patch6
-rw-r--r--target/linux/lantiq/patches-4.9/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch2
3 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/lantiq/patches-4.9/0008-MIPS-lantiq-backport-old-timer-code.patch b/target/linux/lantiq/patches-4.9/0008-MIPS-lantiq-backport-old-timer-code.patch
index 55255037fa..f36a79a83b 100644
--- a/target/linux/lantiq/patches-4.9/0008-MIPS-lantiq-backport-old-timer-code.patch
+++ b/target/linux/lantiq/patches-4.9/0008-MIPS-lantiq-backport-old-timer-code.patch
@@ -176,7 +176,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
-obj-y := prom.o sysctrl.o clk.o reset.o dma.o gptu.o dcdc.o
+obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o
- obj-y += vmmc.o tffs.o
+ obj-y += vmmc.o
--- /dev/null
+++ b/arch/mips/lantiq/xway/timer.c
diff --git a/target/linux/lantiq/patches-4.9/0026-NET-multi-phy-support.patch b/target/linux/lantiq/patches-4.9/0026-NET-multi-phy-support.patch
index a25e87a9cc..fbd5a0436f 100644
--- a/target/linux/lantiq/patches-4.9/0026-NET-multi-phy-support.patch
+++ b/target/linux/lantiq/patches-4.9/0026-NET-multi-phy-support.patch
@@ -11,7 +11,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/drivers/net/phy/phy.c
+++ b/drivers/net/phy/phy.c
-@@ -1000,7 +1000,8 @@ void phy_state_machine(struct work_struc
+@@ -1032,7 +1032,8 @@ void phy_state_machine(struct work_struc
/* If the link is down, give up on negotiation for now */
if (!phydev->link) {
phydev->state = PHY_NOLINK;
@@ -21,7 +21,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
phydev->adjust_link(phydev->attached_dev);
break;
}
-@@ -1083,7 +1084,8 @@ void phy_state_machine(struct work_struc
+@@ -1115,7 +1116,8 @@ void phy_state_machine(struct work_struc
netif_carrier_on(phydev->attached_dev);
} else {
phydev->state = PHY_NOLINK;
@@ -31,7 +31,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
}
phydev->adjust_link(phydev->attached_dev);
-@@ -1095,7 +1097,8 @@ void phy_state_machine(struct work_struc
+@@ -1127,7 +1129,8 @@ void phy_state_machine(struct work_struc
case PHY_HALTED:
if (phydev->link) {
phydev->link = 0;
diff --git a/target/linux/lantiq/patches-4.9/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch b/target/linux/lantiq/patches-4.9/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch
index d79b4010f8..d875c55fb8 100644
--- a/target/linux/lantiq/patches-4.9/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch
+++ b/target/linux/lantiq/patches-4.9/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch
@@ -29,7 +29,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+++ b/arch/mips/lantiq/xway/Makefile
@@ -2,4 +2,7 @@ obj-y := prom.o sysctrl.o clk.o reset.o
- obj-y += vmmc.o tffs.o
+ obj-y += vmmc.o
+obj-y += eth_mac.o
+obj-$(CONFIG_PCI) += ath5k_eep.o