aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-3.7/0121-owrt-lantiq-dtb-image-hack.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-12-15 01:59:45 +0000
committerJohn Crispin <john@openwrt.org>2012-12-15 01:59:45 +0000
commit3a948770cf46732ba4e2ebe667efc3be164780e3 (patch)
treea332a0212fc1d8831ea73fa20841bd252c468916 /target/linux/lantiq/patches-3.7/0121-owrt-lantiq-dtb-image-hack.patch
parent240a3a38e1711857921d31b73a81a4ef9e8a3117 (diff)
downloadupstream-3a948770cf46732ba4e2ebe667efc3be164780e3.tar.gz
upstream-3a948770cf46732ba4e2ebe667efc3be164780e3.tar.bz2
upstream-3a948770cf46732ba4e2ebe667efc3be164780e3.zip
add linux-v3.7
SVN-Revision: 34687
Diffstat (limited to 'target/linux/lantiq/patches-3.7/0121-owrt-lantiq-dtb-image-hack.patch')
-rw-r--r--target/linux/lantiq/patches-3.7/0121-owrt-lantiq-dtb-image-hack.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/target/linux/lantiq/patches-3.7/0121-owrt-lantiq-dtb-image-hack.patch b/target/linux/lantiq/patches-3.7/0121-owrt-lantiq-dtb-image-hack.patch
new file mode 100644
index 0000000000..eef7da47b4
--- /dev/null
+++ b/target/linux/lantiq/patches-3.7/0121-owrt-lantiq-dtb-image-hack.patch
@@ -0,0 +1,44 @@
+From d8f83a608bc854dbbe6b2ea5436e9b34516af8e4 Mon Sep 17 00:00:00 2001
+From: John Crispin <blogic@openwrt.org>
+Date: Thu, 6 Dec 2012 16:09:08 +0100
+Subject: [PATCH 121/123] owrt: lantiq dtb image hack
+
+---
+ arch/mips/lantiq/prom.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+Index: linux-3.7-rc8/arch/mips/lantiq/prom.c
+===================================================================
+--- linux-3.7-rc8.orig/arch/mips/lantiq/prom.c 2012-12-14 23:08:36.451576994 +0100
++++ linux-3.7-rc8/arch/mips/lantiq/prom.c 2012-12-14 23:08:36.607576999 +0100
+@@ -72,6 +72,8 @@
+ return 0;
+ }
+
++extern struct boot_param_header __image_dtb;
++
+ void __init plat_mem_setup(void)
+ {
+ ioport_resource.start = IOPORT_RESOURCE_START;
+@@ -85,7 +87,7 @@
+ * Load the builtin devicetree. This causes the chosen node to be
+ * parsed resulting in our memory appearing
+ */
+- __dt_setup_arch(&__dtb_start);
++ __dt_setup_arch(&__image_dtb);
+
+ of_scan_flat_dt(early_init_dt_scan_model, NULL);
+ }
+Index: linux-3.7-rc8/arch/mips/lantiq/Makefile
+===================================================================
+--- linux-3.7-rc8.orig/arch/mips/lantiq/Makefile 2012-12-14 23:08:36.459576996 +0100
++++ linux-3.7-rc8/arch/mips/lantiq/Makefile 2012-12-15 01:40:16.519805129 +0100
+@@ -6,8 +6,6 @@
+
+ obj-y := irq.o clk.o prom.o
+
+-obj-y += dts/
+-
+ obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
+
+ obj-$(CONFIG_SOC_TYPE_XWAY) += xway/