aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-3.7/0115-NET-PHY-adds-driver-for-lantiq-PHY11G.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-01-28 17:44:20 +0000
committerJohn Crispin <john@openwrt.org>2013-01-28 17:44:20 +0000
commit0de095593195b8c45dcecb4343271afbedce32df (patch)
treeb93cbf751ceb44b9b4b9500cae0cf7a2d2efc15d /target/linux/lantiq/patches-3.7/0115-NET-PHY-adds-driver-for-lantiq-PHY11G.patch
parent0183df8ed9155b813564aafadace08ee04d64456 (diff)
downloadupstream-0de095593195b8c45dcecb4343271afbedce32df.tar.gz
upstream-0de095593195b8c45dcecb4343271afbedce32df.tar.bz2
upstream-0de095593195b8c45dcecb4343271afbedce32df.zip
refresh patches
SVN-Revision: 35355
Diffstat (limited to 'target/linux/lantiq/patches-3.7/0115-NET-PHY-adds-driver-for-lantiq-PHY11G.patch')
-rw-r--r--target/linux/lantiq/patches-3.7/0115-NET-PHY-adds-driver-for-lantiq-PHY11G.patch22
1 files changed, 8 insertions, 14 deletions
diff --git a/target/linux/lantiq/patches-3.7/0115-NET-PHY-adds-driver-for-lantiq-PHY11G.patch b/target/linux/lantiq/patches-3.7/0115-NET-PHY-adds-driver-for-lantiq-PHY11G.patch
index 18d6bb8d3d..15b2ebf64e 100644
--- a/target/linux/lantiq/patches-3.7/0115-NET-PHY-adds-driver-for-lantiq-PHY11G.patch
+++ b/target/linux/lantiq/patches-3.7/0115-NET-PHY-adds-driver-for-lantiq-PHY11G.patch
@@ -11,11 +11,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
3 files changed, 184 insertions(+)
create mode 100644 drivers/net/phy/lantiq.c
-Index: linux-3.7.1/drivers/net/phy/Kconfig
-===================================================================
---- linux-3.7.1.orig/drivers/net/phy/Kconfig 2012-12-21 10:30:28.953462268 +0100
-+++ linux-3.7.1/drivers/net/phy/Kconfig 2012-12-21 10:30:29.609462283 +0100
-@@ -150,6 +150,11 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -150,6 +150,11 @@ config MICREL_PHY
---help---
Currently has a driver for the KSZ8041
@@ -27,11 +25,9 @@ Index: linux-3.7.1/drivers/net/phy/Kconfig
config FIXED_PHY
bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
depends on PHYLIB=y
-Index: linux-3.7.1/drivers/net/phy/Makefile
-===================================================================
---- linux-3.7.1.orig/drivers/net/phy/Makefile 2012-12-21 10:30:28.953462268 +0100
-+++ linux-3.7.1/drivers/net/phy/Makefile 2012-12-21 10:30:29.609462283 +0100
-@@ -38,6 +38,7 @@
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -39,6 +39,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
obj-$(CONFIG_DP83640_PHY) += dp83640.o
obj-$(CONFIG_STE10XP) += ste10Xp.o
obj-$(CONFIG_MICREL_PHY) += micrel.o
@@ -39,10 +35,8 @@ Index: linux-3.7.1/drivers/net/phy/Makefile
obj-$(CONFIG_MDIO_OCTEON) += mdio-octeon.o
obj-$(CONFIG_MICREL_KS8995MA) += spi_ks8995.o
obj-$(CONFIG_AT803X_PHY) += at803x.o
-Index: linux-3.7.1/drivers/net/phy/lantiq.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.7.1/drivers/net/phy/lantiq.c 2012-12-21 11:47:10.721571920 +0100
+--- /dev/null
++++ b/drivers/net/phy/lantiq.c
@@ -0,0 +1,220 @@
+/*
+ * This program is free software; you can redistribute it and/or modify