aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-2.6.39/120-falcon-i2c.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-06-04 13:35:55 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-06-04 13:35:55 +0000
commit763b58c30c60ccc3864e46cf916666766b060f23 (patch)
treed78edd4703568b04a14abcf816ce98cfaa8b8bce /target/linux/lantiq/patches-2.6.39/120-falcon-i2c.patch
parent3715fa33fe61c37e37c7bc49abe59a986938f3e9 (diff)
downloadupstream-763b58c30c60ccc3864e46cf916666766b060f23.tar.gz
upstream-763b58c30c60ccc3864e46cf916666766b060f23.tar.bz2
upstream-763b58c30c60ccc3864e46cf916666766b060f23.zip
update to 2.6.39.1
patch from Peter Wagner SVN-Revision: 27104
Diffstat (limited to 'target/linux/lantiq/patches-2.6.39/120-falcon-i2c.patch')
-rw-r--r--target/linux/lantiq/patches-2.6.39/120-falcon-i2c.patch7
1 files changed, 3 insertions, 4 deletions
diff --git a/target/linux/lantiq/patches-2.6.39/120-falcon-i2c.patch b/target/linux/lantiq/patches-2.6.39/120-falcon-i2c.patch
index 3dd873be74..c5d39c8c21 100644
--- a/target/linux/lantiq/patches-2.6.39/120-falcon-i2c.patch
+++ b/target/linux/lantiq/patches-2.6.39/120-falcon-i2c.patch
@@ -1,16 +1,15 @@
--- a/drivers/i2c/busses/Makefile
+++ b/drivers/i2c/busses/Makefile
-@@ -74,6 +74,7 @@
+@@ -82,5 +82,6 @@ obj-$(CONFIG_I2C_SIBYTE) += i2c-sibyte.o
obj-$(CONFIG_I2C_STUB) += i2c-stub.o
obj-$(CONFIG_SCx200_ACB) += scx200_acb.o
obj-$(CONFIG_SCx200_I2C) += scx200_i2c.o
+obj-$(CONFIG_I2C_FALCON) += i2c-falcon.o
- ifeq ($(CONFIG_I2C_DEBUG_BUS),y)
- EXTRA_CFLAGS += -DDEBUG
+ ccflags-$(CONFIG_I2C_DEBUG_BUS) := -DDEBUG
--- a/drivers/i2c/busses/Kconfig
+++ b/drivers/i2c/busses/Kconfig
-@@ -278,6 +278,10 @@
+@@ -282,6 +282,10 @@ config I2C_POWERMAC
comment "I2C system bus drivers (mostly embedded / system-on-chip)"