aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
authorYushi Nishida <kyro2man@gmx.net>2020-04-03 19:21:06 +0200
committerAlexander Couzens <lynxis@fe80.eu>2020-05-16 04:37:55 +0200
commit78bebe680f67e8967c2baad8a5c07035d431f9d5 (patch)
treea22a4eb714b470d505f31f65ec95e163f04130d5 /target/linux/lantiq/image
parent8097fd4d5f7f0e995db2a80aca03d8258907f85b (diff)
downloadupstream-78bebe680f67e8967c2baad8a5c07035d431f9d5.tar.gz
upstream-78bebe680f67e8967c2baad8a5c07035d431f9d5.tar.bz2
upstream-78bebe680f67e8967c2baad8a5c07035d431f9d5.zip
lantiq/xrx200: add support for the Fritzbox 7360v2
This commit adds support for the Fritzbox 7360v2 CPU: VR9 500MHz Cores: 2 RAM: 128 MB NOR-Flash: 32 MB WLAN: AR9287-BL1A DECT is not working. Thanks Sebastian Ortwein for adding 7360SL. The dts file is derived from avm_fritz7360sl.dts. Firmware can be flashed with this method: 1.) Set your client IP to 192.168.178.2 2.) Power on your your Fritzbox and connect to 192.168.178.1 via ftp in the first 5 seconds. 3.) login with adam2/adam2 4.) type into the ftp prompt: passive binary debug 1 quote MEDIA FLSH // (not FLASH) put openwrt-lantiq-xrx200-avm_fritz7360v2-squashfs-sysupgrade.bin mtd1 // using the correct location for the squashfs-sysupgrade-firmware.bin 5.) wait till red light flashing turns off. 6.) type: exit Run tested with kernel 4.19 and 5.4 on Fritzbox 7360 V2. Issue: Ethernet speed is slow, (iperf between a Xiaomi mir3g and this router results in <80Mbits throughput with a wired cable when using the gbit ports.) Signed-off-by: Yushi Nishida <kyro2man@gmx.net>
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/vr9.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/vr9.mk b/target/linux/lantiq/image/vr9.mk
index 167c57c7c4..d59605a158 100644
--- a/target/linux/lantiq/image/vr9.mk
+++ b/target/linux/lantiq/image/vr9.mk
@@ -127,6 +127,16 @@ define Device/avm_fritz7360sl
endef
TARGET_DEVICES += avm_fritz7360sl
+define Device/avm_fritz7360v2
+ $(Device/AVM)
+ DEVICE_MODEL := FRITZ!Box 7360
+ DEVICE_VARIANT := v2
+ IMAGE_SIZE := 32128k
+ DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-basic kmod-usb-dwc2
+ SUPPORTED_DEVICES += FRITZ7360V2
+endef
+TARGET_DEVICES += avm_fritz7360v2
+
define Device/avm_fritz7362sl
$(Device/AVM)
$(Device/NAND)