aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-07-19 18:06:33 +0000
committerJohn Crispin <blogic@openwrt.org>2011-07-19 18:06:33 +0000
commit251518332b5f3318117d422cb8abac88d1dcb611 (patch)
tree6ffb4efcbb64ae20a9fd02784efb7b0facaf2f1f /target/linux/lantiq/image
parent6ab7823969fafb944b0edcaf6a2b40dcad0dcaf3 (diff)
downloadupstream-251518332b5f3318117d422cb8abac88d1dcb611.tar.gz
upstream-251518332b5f3318117d422cb8abac88d1dcb611.tar.bz2
upstream-251518332b5f3318117d422cb8abac88d1dcb611.zip
add support for more lantiq AR9 boards
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27694 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index f22f2c09e2..8c607b2151 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/image.mk
JFFS2_BLOCKSIZE = 64k 128k 256k
-ase_cmdline=-console=ttyLTQ1,115200 rootfstype=squashfs,jffs2
+ase_cmdline=-console=ttyLTQ0,115200 rootfstype=squashfs,jffs2
xway_cmdline=-console=ttyLTQ1,115200 rootfstype=squashfs,jffs2
falcon_cmdline=-console=ttyLTQ0,115200 rootfstype=squashfs,jffs2
@@ -199,6 +199,14 @@ endef
endif
ifeq ($(CONFIG_TARGET_lantiq_ar9),y)
+define Image/BuildKernel/Profile/WBMR
+ $(call Image/BuildKernel/Template,WBMR,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/WBMR
+ $(call Image/Build/$(1),$(1),WBMR)
+endef
+
define Image/BuildKernel/Profile/DGN3500B
$(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
endef
@@ -208,11 +216,13 @@ define Image/Build/Profile/DGN3500B
endef
define Image/BuildKernel/Profile/Generic
+ $(call Image/BuildKernel/Template,WBMR,$(xway_cmdline))
$(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
$(call Image/BuildKernel/Template,NONE)
endef
define Image/Build/Profile/Generic
+ $(call Image/Build/$(1),$(1),WBMR)
$(call Image/Build/$(1),$(1),DGN3500B)
$(call Image/Build/$(1),$(1),NONE)
$(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs