aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/falcon.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-24 18:38:53 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-24 18:38:53 +0100
commit09ee51c614d95904010f3646938b5b85c73bebec (patch)
tree5153742aab109ab81bb49fbb2386d903b019c6c4 /target/linux/lantiq/image/falcon.mk
parentd9a0794f8d56236b2984c15948d93aa5d320e16e (diff)
downloadupstream-09ee51c614d95904010f3646938b5b85c73bebec.tar.gz
upstream-09ee51c614d95904010f3646938b5b85c73bebec.tar.bz2
upstream-09ee51c614d95904010f3646938b5b85c73bebec.zip
lantiq: define SOC only once for uniform targets
In lantiq there are several subtarget where all devices have the same value set to the SOC variable for each device individually. This patch introduces a non-device-dependent variable DEFAULT_SOC, which is used if no specific SOC is set for a device, and thus reduces the number of redundant definitions drastically. This is applied to all subtargets except xway, as only the latter has two different SOCs. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/lantiq/image/falcon.mk')
-rw-r--r--target/linux/lantiq/image/falcon.mk12
1 files changed, 0 insertions, 12 deletions
diff --git a/target/linux/lantiq/image/falcon.mk b/target/linux/lantiq/image/falcon.mk
index e6aae1240b..a5490f6e68 100644
--- a/target/linux/lantiq/image/falcon.mk
+++ b/target/linux/lantiq/image/falcon.mk
@@ -2,7 +2,6 @@ define Device/lantiq_easy88388
DEVICE_VENDOR := Lantiq
DEVICE_MODEL := EASY88388 Falcon FTTDP8 Reference Board
IMAGE_SIZE := 7424k
- SOC := falcon
endef
TARGET_DEVICES += lantiq_easy88388
@@ -10,7 +9,6 @@ define Device/lantiq_easy88444
DEVICE_VENDOR := Lantiq
DEVICE_MODEL := EASY88444 Falcon FTTdp G.FAST Reference Board
IMAGE_SIZE := 7424k
- SOC := falcon
endef
TARGET_DEVICES += lantiq_easy88444
@@ -19,7 +17,6 @@ define Device/lantiq_easy98020
DEVICE_MODEL := Falcon SFU Reference Board (EASY98020)
DEVICE_VARIANT := v1.0-v1.7
IMAGE_SIZE := 7424k
- SOC := falcon
endef
TARGET_DEVICES += lantiq_easy98020
@@ -28,7 +25,6 @@ define Device/lantiq_easy98020-v18
DEVICE_MODEL := Falcon SFU Reference Board (EASY98020)
DEVICE_VARIANT := v1.8
IMAGE_SIZE := 7424k
- SOC := falcon
endef
TARGET_DEVICES += lantiq_easy98020-v18
@@ -36,7 +32,6 @@ define Device/lantiq_easy98021
DEVICE_VENDOR := Lantiq
DEVICE_MODEL := Falcon HGU Reference Board (EASY98021)
IMAGE_SIZE := 7424k
- SOC := falcon
endef
TARGET_DEVICES += lantiq_easy98021
@@ -45,7 +40,6 @@ define Device/lantiq_easy98035synce
DEVICE_MODEL := Falcon SFP Stick (EASY98035SYNCE)
DEVICE_VARIANT := with Synchronous Ethernet
IMAGE_SIZE := 7424k
- SOC := falcon
endef
TARGET_DEVICES += lantiq_easy98035synce
@@ -54,7 +48,6 @@ define Device/lantiq_easy98035synce1588
DEVICE_MODEL := Falcon SFP Stick (EASY98035SYNCE1588)
DEVICE_VARIANT := with SyncE and IEEE1588
IMAGE_SIZE := 7424k
- SOC := falcon
endef
TARGET_DEVICES += lantiq_easy98035synce1588
@@ -63,7 +56,6 @@ define Device/lantiq_easy98000-nand
DEVICE_MODEL := EASY98000 Falcon Eval Board
DEVICE_VARIANT := NAND
IMAGE_SIZE := 3904k
- SOC := falcon
DEVICE_PACKAGES := kmod-dm9000 kmod-i2c-lantiq kmod-eeprom-at24
endef
TARGET_DEVICES += lantiq_easy98000-nand
@@ -73,7 +65,6 @@ define Device/lantiq_easy98000-nor
DEVICE_MODEL := EASY98000 Falcon Eval Board
DEVICE_VARIANT := NOR
IMAGE_SIZE := 3904k
- SOC := falcon
DEVICE_PACKAGES := kmod-dm9000 kmod-i2c-lantiq kmod-eeprom-at24
endef
TARGET_DEVICES += lantiq_easy98000-nor
@@ -83,7 +74,6 @@ define Device/lantiq_easy98000-sflash
DEVICE_MODEL := EASY98000 Falcon Eval Board
DEVICE_VARIANT := SFLASH
IMAGE_SIZE := 7424k
- SOC := falcon
DEVICE_PACKAGES := kmod-dm9000 kmod-i2c-lantiq kmod-eeprom-at24
endef
TARGET_DEVICES += lantiq_easy98000-sflash
@@ -92,7 +82,6 @@ define Device/lantiq_falcon-mdu
DEVICE_VENDOR := Lantiq
DEVICE_MODEL := Falcon / VINAXdp MDU Board
IMAGE_SIZE := 7424k
- SOC := falcon
endef
TARGET_DEVICES += lantiq_falcon-mdu
@@ -100,6 +89,5 @@ define Device/lantiq_falcon-sfp
DEVICE_VENDOR := Lantiq
DEVICE_MODEL := Falcon SFP Stick
IMAGE_SIZE := 7424k
- SOC := falcon
endef
TARGET_DEVICES += lantiq_falcon-sfp