aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-24 18:35:25 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-24 18:35:25 +0100
commitd9a0794f8d56236b2984c15948d93aa5d320e16e (patch)
tree46a5b8fc074c64d5ff4752917138538a074297ed /target/linux/lantiq/image/Makefile
parent44cb4fd5e681ee72ef5e81c0442c2651e18ae6f6 (diff)
downloadupstream-d9a0794f8d56236b2984c15948d93aa5d320e16e.tar.gz
upstream-d9a0794f8d56236b2984c15948d93aa5d320e16e.tar.bz2
upstream-d9a0794f8d56236b2984c15948d93aa5d320e16e.zip
lantiq: move DTS_DIR variable out of Device definition
The DTS_DIR variable is not a device variable, thus it should not be set inside Device/Default but globally. Fixes: c640370939d7 ("lantiq: use soc_vendor_device scheme on DTS file") Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 3060ff920b..68de191283 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -52,6 +52,8 @@ define Build/fullimage
rm $@.tmp
endef
+DTS_DIR := $(DTS_DIR)/lantiq
+
# Shared device definition: applies to every defined device
define Device/Default
PROFILES = Default
@@ -61,7 +63,6 @@ define Device/Default
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
FILESYSTEMS := squashfs
IMAGE_SIZE :=
- DTS_DIR := $(DTS_DIR)/lantiq
DEVICE_DTS = $$(SOC)_$(1)
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
IMAGES := sysupgrade.bin