aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-16 00:21:33 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-22 01:24:23 +0100
commitc640370939d725238aa6200423eb8aabf59ef23e (patch)
treedbc336cb5cf8f52750c0c6ced21ef981da728601 /target/linux/lantiq/image/Makefile
parentde6dd7a8db1c073734113156668bca6792dc123d (diff)
downloadupstream-c640370939d725238aa6200423eb8aabf59ef23e.tar.gz
upstream-c640370939d725238aa6200423eb8aabf59ef23e.tar.bz2
upstream-c640370939d725238aa6200423eb8aabf59ef23e.zip
lantiq: use soc_vendor_device scheme on DTS file
This renames lantiq DTS(I) files to follow soc_vendor_device scheme. This will make DTS files easier to maintain. As a side effect, DTS file name can be derived from device node names now, only having to specify a SOC variable in Makefiles. While at it, move files to arch/mips/boot/dts/lantiq subfolder. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index a2052ef924..3060ff920b 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -61,6 +61,8 @@ define Device/Default
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
FILESYSTEMS := squashfs
IMAGE_SIZE :=
+ DTS_DIR := $(DTS_DIR)/lantiq
+ DEVICE_DTS = $$(SOC)_$(1)
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)