aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorValentin Spreckels <Valentin.Spreckels@Informatik.Uni-Oldenburg.DE>2018-03-18 20:27:50 +0100
committerMathias Kresin <dev@kresin.me>2018-03-18 22:22:38 +0100
commitac1c31c2595a7af3bc5bdf97d48b85278fb0eeff (patch)
tree4be6f9291f6000aaed4544797ceb7876c00555b5 /target/linux/lantiq/image/Makefile
parent26a9f01fc6c223286459d3178ef12813bac8d342 (diff)
downloadupstream-ac1c31c2595a7af3bc5bdf97d48b85278fb0eeff.tar.gz
upstream-ac1c31c2595a7af3bc5bdf97d48b85278fb0eeff.tar.bz2
upstream-ac1c31c2595a7af3bc5bdf97d48b85278fb0eeff.zip
lantiq: fix AVM initramfs image
Create an initramfs that can be used with the EVA bootloader. Signed-off-by: Valentin Spreckels <Valentin.Spreckels@Informatik.Uni-Oldenburg.DE>
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index e52e43c6e5..e6fbc1dbf8 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -101,6 +101,7 @@ endef
define Device/AVM
KERNEL := kernel-bin | append-dtb | lzma | eva-image
+ KERNEL_INITRAMFS := $$(KERNEL)
IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-avm-fakeroot | \
append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
endef