aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-12-11 10:27:17 +0100
committerMathias Kresin <dev@kresin.me>2017-12-11 12:43:29 +0100
commitab6620e817259a4558dfcf64f9110a0cb4972557 (patch)
treef27aff87f6153d2db630249eb10c25492b3e5239 /target/linux/lantiq/image/Makefile
parentd810a2aebf30ce2f493e7a519177021c42f10ba4 (diff)
downloadupstream-ab6620e817259a4558dfcf64f9110a0cb4972557.tar.gz
upstream-ab6620e817259a4558dfcf64f9110a0cb4972557.tar.bz2
upstream-ab6620e817259a4558dfcf64f9110a0cb4972557.zip
lantiq: dgn3500 drop worldwide suffix
Remove the WW suffix, everything without a region suffix is world wide anyway. While at it, normalise the image filenames by using only lower case characters. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index f6795ee61a..596c46110f 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -368,19 +368,19 @@ DGN3500_KERNEL_OFFSET_DEC=327680
define Device/DGN3500
IMAGE_SIZE := 16000k
IMAGES := \
- sysupgrade-NA.bin sysupgrade-WW.bin \
- factory-NA.img factory-WW.img
- IMAGE/sysupgrade-NA.bin := \
+ sysupgrade-na.bin sysupgrade.bin \
+ factory-na.img factory.img
+ IMAGE/sysupgrade-na.bin := \
append-kernel | append-rootfs | dgn3500-sercom-footer 0x0 "NA" | \
pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
- IMAGE/sysupgrade-WW.bin := \
+ IMAGE/sysupgrade.bin := \
append-kernel | append-rootfs | dgn3500-sercom-footer 0x0 "WW" | \
pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
- IMAGE/factory-NA.img := \
+ IMAGE/factory-na.img := \
pad-extra $(DGN3500_KERNEL_OFFSET_DEC) | append-kernel | append-rootfs | \
dgn3500-sercom-footer $(DGN3500_KERNEL_OFFSET_HEX) "NA" | pad-rootfs | \
check-size 16320k | pad-to 16384k
- IMAGE/factory-WW.img := \
+ IMAGE/factory.img := \
pad-extra $(DGN3500_KERNEL_OFFSET_DEC) | append-kernel | append-rootfs | \
dgn3500-sercom-footer $(DGN3500_KERNEL_OFFSET_HEX) "WW" | pad-rootfs | \
check-size 16320k | pad-to 16384k