aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-11-02 20:07:47 +0000
committerJohn Crispin <john@openwrt.org>2012-11-02 20:07:47 +0000
commita9ad36b7f1da67dfefcaf9ecb07b8507b3c3a23a (patch)
treeae2fb2b6e82d5a4002302d7bd4b3b1eaca39cba2 /target/linux/lantiq/image/Makefile
parentc8ae6dac56d9b2ed2067c378d39654fbf4cce33b (diff)
downloadupstream-a9ad36b7f1da67dfefcaf9ecb07b8507b3c3a23a.tar.gz
upstream-a9ad36b7f1da67dfefcaf9ecb07b8507b3c3a23a.tar.bz2
upstream-a9ad36b7f1da67dfefcaf9ecb07b8507b3c3a23a.zip
adds dts files and make devicetree images buildable
SVN-Revision: 34064
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile24
1 files changed, 15 insertions, 9 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 96179a5bc1..de5365e676 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -21,7 +21,12 @@ endef
define PatchKernelLzma
cp $(KDIR)/vmlinux $(KDIR)/vmlinux-$(1)
+ifeq ($(CONFIG_LINUX_3_5),y)
+ $(LINUX_DIR)/scripts/dtc/dtc -O dtb -o $(KDIR)/$(1).dtb ./$(1).dts
+ $(STAGING_DIR_HOST)/bin/patch-dtb $(KDIR)/vmlinux-$(1) $(KDIR)/$(1).dtb
+else
$(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux-$(1) '$(strip $(2))'
+endif
$(call CompressLzma,$(KDIR)/vmlinux-$(1),$(KDIR)/vmlinux-$(1).lzma)
endef
@@ -190,17 +195,18 @@ endif
ifeq ($(CONFIG_TARGET_lantiq_ase),y)
-Image/BuildKernel/Profile/EASY50601=$(call Image/BuildKernel/Template,EASY50601,$(ase_cmdline))
-Image/Build/Profile/EASY50601=$(call Image/Build/$(1),$(1),EASY50601)
+Image/BuildKernel/Profile/DGN1000B=$(call Image/BuildKernel/Template,DGN1000B)
+Image/Build/Profile/DGN1000B=$(call Image/Build/$(1),$(1),DGN1000B)
-define Image/BuildKernel/Profile/Generic
- $(call Image/BuildKernel/Template,NONE)
-endef
+endif
+
+ifeq ($(CONFIG_TARGET_lantiq_xway),y)
+
+Image/BuildKernel/Profile/EASY80920-NAND=$(call Image/BuildKernel/Template,EASY80920-NAND)
+Image/Build/Profile/EASY80920-NAND=$(call Image/Build/$(1),$(1),EASY80920-NAND)
+Image/BuildKernel/Profile/EASY80920-NOR=$(call Image/BuildKernel/Template,EASY80920-NOR)
+Image/Build/Profile/EASY80920-NOR=$(call Image/Build/$(1),$(1),EASY80920-NOR)
-define Image/Build/Profile/Generic
- $(call Image/Build/$(1),$(1),NONE)
- $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs
-endef
endif
ifeq ($(CONFIG_TARGET_lantiq_vr9),y)