aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorTino Reichardt <milky-lede@mcmilk.de>2017-02-26 21:28:28 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-06-03 21:14:07 +0200
commit995ad357f90aacb2ce6cae82c4c1f4f86d8f928e (patch)
tree06f93fa44f4d8a28c34664931b747700b668a875 /target/linux/lantiq/image/Makefile
parent9b321bc60de3ee6f41fa5bcb6593e07399782714 (diff)
downloadupstream-995ad357f90aacb2ce6cae82c4c1f4f86d8f928e.tar.gz
upstream-995ad357f90aacb2ce6cae82c4c1f4f86d8f928e.tar.bz2
upstream-995ad357f90aacb2ce6cae82c4c1f4f86d8f928e.zip
lantiq: enable Netgear DGN1000B image build
Enable the building of Netgear DGN1000B images. I have an example device here, but it was not tested currently. Also WLAN and USB is not ready in the moment. This is just the proper way, so that developing on this device is known to be done in the near future. Signed-off-by: Tino Reichardt <milky-lede@mcmilk.de>
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 12763bbdb1..572c9b3ca7 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -106,6 +106,20 @@ define Device/AVM
KERNEL := kernel-bin | append-dtb | lzma | eva-image
endef
+ifeq ($(SUBTARGET),ase)
+
+define Device/DGN1000B
+ IMAGE_SIZE := 6000k
+ DEVICE_DTS := DGN1000B
+ DEVICE_TITLE := Netgear DGN1000B
+ DEVICE_PACKAGES := kmod-ltq-adsl-ase kmod-ltq-adsl-ase-mei \
+ kmod-ltq-adsl-ase-fw-b kmod-ltq-atm-ase \
+ ltq-adsl-app ppp-mod-pppoe
+endef
+TARGET_DEVICES += DGN1000B
+
+endif
+
ifeq ($(SUBTARGET),xway_legacy)
define Device/ARV4520PW