aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2016-10-02 18:39:50 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2016-11-27 17:40:20 +0100
commit93715427835e747f0e0b348c8a3ce91dd68ef4f9 (patch)
treee16da2bf547e204e6a929324b405aea71281857e /target/linux/lantiq/image/Makefile
parent5cdbc8632962a4e4451db771597cf84e1c5046d5 (diff)
downloadupstream-93715427835e747f0e0b348c8a3ce91dd68ef4f9.tar.gz
upstream-93715427835e747f0e0b348c8a3ce91dd68ef4f9.tar.bz2
upstream-93715427835e747f0e0b348c8a3ce91dd68ef4f9.zip
lantiq: add Falcon support
This adds support for the Intel Falcon SoC for GPON. Support for the Falcon SoC was removed in commit c8218363951 svn rev: 40392 from OpenWrt, this commit adds it again. This patch adds a new subtarget for the Falcon SoC, but it still misses all the drivers needed to control the GPON part. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile81
1 files changed, 81 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 2e0fdb3055..490bd543e0 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -565,4 +565,85 @@ TARGET_DEVICES += VGV7519BRN
endif
+
+ifeq ($(SUBTARGET),falcon)
+
+define Device/EASY98000
+ IMAGE_SIZE := 3904k
+ DEVICE_TITLE := EASY98000 - Lantiq Falcon Eval Board NOR
+ DEVICE_DTS := EASY98000NOR
+ DEVICE_PACKAGES := kmod-dm9000 kmod-i2c-lantiq kmod-eeprom-at24
+endef
+TARGET_DEVICES += EASY98000
+
+define Device/EASY98000NAND
+ IMAGE_SIZE := 3904k
+ DEVICE_TITLE := EASY98000 - Lantiq Falcon Eval Board NAND
+ DEVICE_PACKAGES := kmod-dm9000 kmod-i2c-lantiq kmod-eeprom-at24
+endef
+TARGET_DEVICES += EASY98000NAND
+
+define Device/EASY98000SFLASH
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := EASY98000 - Lantiq Falcon Eval Board SFLASH
+ DEVICE_PACKAGES := kmod-dm9000 kmod-i2c-lantiq kmod-eeprom-at24
+endef
+TARGET_DEVICES += EASY98000SFLASH
+
+define Device/FALCON-MDU
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := MDU - Lantiq Falcon / VINAXdp MDU Board
+endef
+TARGET_DEVICES += FALCON-MDU
+
+define Device/EASY88388
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := EASY88388 - Lantiq Falcon FTTDP8 Reference Board
+endef
+TARGET_DEVICES += EASY88388
+
+define Device/EASY88444
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := EASY88444 - Lantiq Falcon FTTdp G.FAST Reference Board
+endef
+TARGET_DEVICES += EASY88444
+
+define Device/FALCON-SFP
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := SFP - Lantiq Falcon SFP Stick
+endef
+TARGET_DEVICES += FALCON-SFP
+
+define Device/EASY98035SYNCE
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := EASY98035SYNCE - Lantiq Falcon SFP Stick with Synchronous Ethernet
+endef
+TARGET_DEVICES += EASY98035SYNCE
+
+define Device/EASY98035SYNCE1588
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := EASY98035SYNCE1588 - Lantiq Falcon SFP Stick with SyncE and IEEE1588
+endef
+TARGET_DEVICES += EASY98035SYNCE1588
+
+define Device/EASY98020
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := EASY98020 - Lantiq Falcon SFU Reference Board
+endef
+TARGET_DEVICES += EASY98020
+
+define Device/EASY98020V18
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := EASY98020V18 - Lantiq Falcon SFU Reference Board V1.8
+endef
+TARGET_DEVICES += EASY98020V18
+
+define Device/EASY98021
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := EASY98021 - Lantiq Falcon HGU Reference Board
+endef
+TARGET_DEVICES += EASY98021
+
+endif
+
$(eval $(call BuildImage))