aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-09 21:14:06 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-11 18:25:06 +0100
commit90daff4cf8a86622012217d3be7ce136c313a896 (patch)
tree5c42cb53114f8953a58327bb3980bbb40423c579 /target/linux/lantiq/image/Makefile
parent14a07fa1f000f962d55bf53cfe9b128448b1f11f (diff)
downloadupstream-90daff4cf8a86622012217d3be7ce136c313a896.tar.gz
upstream-90daff4cf8a86622012217d3be7ce136c313a896.tar.bz2
upstream-90daff4cf8a86622012217d3be7ce136c313a896.zip
build: image: move IMAGE_SIZE to image.mk
IMAGE_SIZE is widely used in many targets. Declare it in the default template to clean up redundant code. This also prevents deriving IMAGE_SIZE unintentionally from the previously defined device. While at it, remove duplicate KERNEL_SIZE declaration. Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile2
1 files changed, 0 insertions, 2 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index d0dc49730b..0ec04af6b3 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -62,14 +62,12 @@ define Device/Default
KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
FILESYSTEMS := squashfs
- IMAGE_SIZE :=
SOC := $(DEFAULT_SOC)
DEVICE_DTS = $$(SOC)_$(1)
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
endef
-DEVICE_VARS += IMAGE_SIZE
define Device/NAND/xway
BLOCKSIZE := 16k