aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-03-25 19:18:37 +0100
committerMathias Kresin <dev@kresin.me>2017-06-24 22:36:38 +0200
commit8e0d7d6574139e1ab4f99926e2cd09f6959d1073 (patch)
tree0c9db24d1d56955b66af556dc51b5f7054ce5b64 /target/linux/lantiq/image/Makefile
parentd165f1f3bcb7330d008d68c2c9b4538c5fd3ebce (diff)
downloadupstream-8e0d7d6574139e1ab4f99926e2cd09f6959d1073.tar.gz
upstream-8e0d7d6574139e1ab4f99926e2cd09f6959d1073.tar.bz2
upstream-8e0d7d6574139e1ab4f99926e2cd09f6959d1073.zip
build: move lzma2eva build step to image-commands.mk
Move it to image-commands.mk so that it can used by other targets with eva based boards as well. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 1b194b3e7b..e0f58af3e2 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -20,9 +20,8 @@ else
UBIFS_OPTS := -m 2048 -e 126KiB -c 4096
endif
-define Build/eva-image
- lzma2eva $(KERNEL_LOADADDR) $(KERNEL_LOADADDR) $@ $@.new
- ( dd if=$@.new bs=64k conv=sync; cat ./eva.dummy.squashfs; ) > $@
+define Build/append-avm-fakeroot
+ cat ./eva.dummy.squashfs >> $@
endef
define Build/dgn3500-sercom-footer
@@ -104,6 +103,8 @@ endef
define Device/AVM
KERNEL := kernel-bin | append-dtb | lzma | eva-image
+ IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-avm-fakeroot | \
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
endef
ifeq ($(SUBTARGET),ase)