aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-24 18:48:47 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-24 18:48:47 +0100
commit719e106855399b0679d174f2368c3e3b15b90d30 (patch)
treeb0a5897ba59ad15fdf15d75e12acad5b80b1cc9e /target/linux/lantiq/image/Makefile
parent09ee51c614d95904010f3646938b5b85c73bebec (diff)
downloadupstream-719e106855399b0679d174f2368c3e3b15b90d30.tar.gz
upstream-719e106855399b0679d174f2368c3e3b15b90d30.tar.bz2
upstream-719e106855399b0679d174f2368c3e3b15b90d30.zip
lantiq: fix setting SOC to DEFAULT_SOC
This adds the missing assignment of DEFAULT_SOC to the SOC variable by default. Fixes: 09ee51c614d9 ("lantiq: define SOC only once for uniform targets") Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index d385cdca7b..4cd9b4ab48 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -63,6 +63,7 @@ define Device/Default
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
FILESYSTEMS := squashfs
IMAGE_SIZE :=
+ SOC := $(DEFAULT_SOC)
DEVICE_DTS = $$(SOC)_$(1)
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
IMAGES := sysupgrade.bin