aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorAlex Maclean <monkeh@monkeh.net>2017-03-06 23:25:37 +0000
committerMathias Kresin <dev@kresin.me>2017-03-08 19:06:04 +0100
commit6254a2028c181fe9863dc7758d47eda667b4f397 (patch)
treeb8c9ee0eef7cc7176ba9d2890dbde7f92a2d3073 /target/linux/lantiq/image/Makefile
parenta9b74f9f817e50659236a093a1a20c8931b6d9d0 (diff)
downloadupstream-6254a2028c181fe9863dc7758d47eda667b4f397.tar.gz
upstream-6254a2028c181fe9863dc7758d47eda667b4f397.tar.bz2
upstream-6254a2028c181fe9863dc7758d47eda667b4f397.zip
lantiq: add support for the Alpha ASL56026
The ASL56026 is a VDSL2 router with dual 100mbit ethernet, also known as the ECI B-FOCuS V-2FUb/I. CPU: Lantiq XRX268 v1.1 at 333MHz Modem: Lantiq VRX208 RAM: 32MiB DDR2 at 167MHz Flash: 8MiB NOR, Spansion S29GL064N90TF04 UART is at JP1: Pin 1 TX Pin 2 GND Pin 3 +3.3V Pin 4 NC Pin 5 RX Boot selection pins are exposed via several resistor jumpers: boot_sel0 is at J15, on the rear of the board. Default is high. boot_sel1 is at J3, next to the flash - it is also the flash CE# pin. Default is low. boot_sel2 is at J12, directly below the SoC. Default is low. boot_sel3 is at J16, on the rear of the board. Default is low. The boot_sel pins should never be shorted, the jumper must be moved or a lower value resistor used to change the pull (existing resistors are 4k7, 1k should work) To install with the stock bootloader you must break the built in image selection process which uses at least the following vars: f_upgrade_addr, f_upgrade2_addr, loadaddr, kernel_addr, activeregion, committedregion This is done by setting loadaddr and both f_upgrade_addr vars to the same address: VR9 # setenv loadaddr 0xB0040000 VR9 # setenv f_upgrade_addr 0xB0040000 VR9 # setenv f_upgrade2_addr 0xB0040000 VR9 # saveenv Then flash the firmware image: VR9 # tftpboot 0x81000000 lede-lantiq-xrx200-ASL56026-squashfs-sysupgrade.bin VR9 # erase B0040000 +${filesize} VR9 # cp.b 0x81000000 0xB0040000 ${filesize} Signed-off-by: Alex Maclean <monkeh@monkeh.net>
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 5daab032ee..12763bbdb1 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -474,6 +474,12 @@ define Device/ARV7519RW22
endef
TARGET_DEVICES += ARV7519RW22
+define Device/ASL56026
+ IMAGE_SIZE := 7488k
+ DEVICE_TITLE := BT OpenReach - ECI VDSL Modem V-2FUb/I
+endef
+TARGET_DEVICES += ASL56026
+
define Device/BTHOMEHUBV5A
$(Device/NAND)
DEVICE_TITLE := BT Home Hub 5A