aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-10 15:41:09 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-21 19:55:12 +0100
commit5b392c7119f23aef10ffc0def9a70e8335f9f3f8 (patch)
tree73e56336895a2944f0cb8dfedfd04f7b7d7d6e67 /target/linux/lantiq/image/Makefile
parentd5812478ad4c882256e43a2ad52ddf0c0944db7b (diff)
downloadupstream-5b392c7119f23aef10ffc0def9a70e8335f9f3f8.tar.gz
upstream-5b392c7119f23aef10ffc0def9a70e8335f9f3f8.tar.bz2
upstream-5b392c7119f23aef10ffc0def9a70e8335f9f3f8.zip
treewide: gather DEVICE_VARS into one place
Place DEVICE_VARS assignments at the top of the file or above Device/Default to make them easier to find. For ramips, remove redundant values already present in parent file. Signed-off-by: Sungbo Eo <mans0n@gorani.run> [do not touch ar71xx, extend commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 0ec04af6b3..87a4110f7e 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -52,6 +52,7 @@ define Build/fullimage
rm $@.tmp
endef
+DEVICE_VARS += SIGNATURE MAGIC CRC32_POLY
DTS_DIR := $(DTS_DIR)/lantiq
# Shared device definition: applies to every defined device
@@ -93,7 +94,6 @@ define Device/lantiqBrnImage
IMAGES := factory.bin
IMAGE/factory.bin := mkbrnimg | check-size $$$$(IMAGE_SIZE)
endef
-DEVICE_VARS += SIGNATURE MAGIC CRC32_POLY
define Device/lantiqFullImage
KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | pad-offset 4 0