aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorThomas Nixon <tom@tomn.co.uk>2017-04-23 22:07:17 +0100
committerMathias Kresin <dev@kresin.me>2017-07-07 07:13:24 +0200
commit50e3659703113df036e755e0d483172c3b809242 (patch)
tree195123601acacf16941fd02d3186980a54cec4c5 /target/linux/lantiq/image/Makefile
parent08cd5b769deb4833b7a20208fa15674f52023fea (diff)
downloadupstream-50e3659703113df036e755e0d483172c3b809242.tar.gz
upstream-50e3659703113df036e755e0d483172c3b809242.tar.bz2
upstream-50e3659703113df036e755e0d483172c3b809242.zip
lantiq: add Netgear DM200 support
Netgear DM200 is an inexpensive VDSL modem: CPU: VRX220 MIPS 34Kc 5.6 @ 500Mhz RAM: 64MiB Flash: 8MiB Ethernet: 1x100M DSL: VDSL2+, ADSL2+ reset button, 3x bi-color LEDs Serial port is 115200 baud, on the 4 pin header; pins from the bottom to top are GND, RX, TX. To upgrade from the vendor firmware, upload factory.img The DM200 bootloader supports flashing over TFTP; hold the reset button while powering on the device, and wait for the power light to start flashing green before releasing. The device is now listening on 192.168.0.1/24, and can be sent a factory.img or a netgear image with a TFTP put. Once the image is loaded, it will be written to the flash, and the device will reboot; this will take a few minutes. Thanks to Edward O'Callaghan and Baptiste Jonglez, who implemented their own ports for this device and provided valuable feedback. Signed-off-by: Thomas Nixon <tom@tomn.co.uk>
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 122a8a5898..1678b1bf55 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -513,6 +513,17 @@ define Device/BTHOMEHUBV5A
endef
TARGET_DEVICES += BTHOMEHUBV5A
+define Device/DM200
+ IMAGES := sysupgrade.bin factory.img
+ IMAGE/factory.img := $$(IMAGE/sysupgrade.bin) | netgear-dni
+ IMAGE_SIZE := 7872k
+ DEVICE_TITLE := Netgear DM200
+ NETGEAR_BOARD_ID := DM200
+ NETGEAR_HW_ID := 29765233+8+0+64+0+0
+endef
+DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID
+TARGET_DEVICES += DM200
+
define Device/EASY80920NAND
$(Device/lantiqFullImage)
IMAGE_SIZE := 64512k