aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2019-03-02 22:33:42 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-03-06 21:58:59 +0100
commit33727ecea5675b477986d0370cfd461495a41fd1 (patch)
treef23a7398331fddd2e9964aa691eecabab3f629b7 /target/linux/lantiq/image/Makefile
parent13c379e5c6e37b3822bf6e4e18cc6317e5b40fbb (diff)
downloadupstream-33727ecea5675b477986d0370cfd461495a41fd1.tar.gz
upstream-33727ecea5675b477986d0370cfd461495a41fd1.tar.bz2
upstream-33727ecea5675b477986d0370cfd461495a41fd1.zip
lantiq: enlarge ZyXEL P-2812HNU-F1 kernel partition (FS#2124)
The current snapshot release kernel with it's 2119245 Byte size is too big to fit into the 2097152 (2MiB) area that was set aside for the kernel. Which causes the device to fail to boot (after an update or even during a fresh install) NAND read: device 0 offset 0x60000, size 0x200000 2097152 bytes read: OK ## Booting kernel from Legacy Image at 80800000 ... Image Name: MIPS OpenWrt Linux-4.14.98 Created: 2019-02-13 9:37:36 UTC Image Type: MIPS Linux Kernel Image (lzma compressed) Data Size: 2119245 Bytes = 2 MiB Load Address: 80002000 Entry Point: 80002000 Verifying Checksum ... Bad Data CRC ERROR: can't get kernel image! This patch fixes the problem by enlarging the kernel partition at the cost of the ubi/data partition behind it. The patch also adds a KERNEL_SIZE variable to the image Makefile to prevent silent corruptions from happening in the future. Please note: The u-boot environment for the router also needs to be updated. So please attach an appropriate serial converter cable and enter the following commands into the u-boot prompt: setenv nboot 'nand read 0x80800000 0x60000 0x300000; bootm 0x80800000' saveenv The wiki has been updated accordingly: <https://openwrt.org/toh/zyxel/p2812hnu-f1> Fixes: FS#2124 Suggested-by: Mafketel (User on bugs.openwrt.org) Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index b59acf4ddc..7e328bf2be 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -553,6 +553,7 @@ define Device/zyxel_p-2812hnu-f1
DEVICE_DTS := P2812HNUF1
DEVICE_TITLE := ZyXEL P-2812HNU-F1
DEVICE_PACKAGES := kmod-rt2800-pci wpad-basic kmod-usb-dwc2 kmod-usb-ledtrig-usbport
+ KERNEL_SIZE := 3072k
SUPPORTED_DEVICES += P2812HNUF1
endef
TARGET_DEVICES += zyxel_p-2812hnu-f1