aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorJohann Neuhauser <johann@it-neuhauser.de>2018-05-17 19:12:35 +0200
committerMathias Kresin <dev@kresin.me>2018-07-18 19:17:46 +0200
commit02d53e6a2113f80ae429664e7990d167fbf44604 (patch)
tree839b9680b321fa840fa3bdfaaaeedaf10e4335bf /target/linux/lantiq/image/Makefile
parentf2f7802148f3d070b27f65b169efebfc6bf8286d (diff)
downloadupstream-02d53e6a2113f80ae429664e7990d167fbf44604.tar.gz
upstream-02d53e6a2113f80ae429664e7990d167fbf44604.tar.bz2
upstream-02d53e6a2113f80ae429664e7990d167fbf44604.zip
lantiq: add support for FritzBox 7312
The FritzBox 7312 is also known as 1&1 WLAN-MODEM. The device is almost the same as FB7330, but only one ETH-Port and no USB. Hardware SoC: Lantiq Xway ARX188 PSB 50812 EL RAM: 64MB DDR1 (Zentel A4S12D40FTP-G5) Ethernet: Atheros 8030 Wireless: Atheros AR9227 b/g/n 2x2 DSL: Lantiq ADSL2+ DECT: Dialog SC14441 Buttons: WiFi, DECT LEDs: Power/DSL, Fon, DECT, WLAN, Info LEDs Power: GPIO#44 (active low) Internet: GPIO#47 (active low) DECT: GPIO#38 (active low) WLAN: GPIO#37 (active low) Info: GPIO#35 (active low) The Fon LED is labeled as internet in avm gpl sources. Buttons WLAN: GPIO#1 (active low) DECT: GPIO#2 (active low) Phy GPIO#03: 25 MHz GPIO#34: Reset (active low) GPIO#39: Int GPIO#42: MII MDIO GPIO#43: MII MDC PCIe GPIO#21: reset (active low) Installation: To install OpenWrt via Eva bootloader, within the first seconds after power on a ftp connection need to be established to the FRITZ!Box at 192.168.178.1 and the the following ftp commands need to be run: ftp> quote USER adam2 ftp> quote PASS adam2 ftp> binary ftp> debug ftp> passive ftp> quote MEDIA FLSH ftp> put /path/to/openwrt-lantiq-xway-avm_fritz7312-squashfs-sysupgrade.bin mtd1 ftp> quote REBOOT Signed-off-by: Johann Neuhauser <johann@it-neuhauser.de>
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index c4419ce629..0bedfcf0af 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -485,6 +485,19 @@ define Device/buffalo_wbmr-hp-g300h-b
endef
TARGET_DEVICES += buffalo_wbmr-hp-g300h-b
+define Device/avm_fritz7312
+ $(Device/AVM)
+ DEVICE_DTS := FRITZ7312
+ IMAGE_SIZE := 15744k
+ DEVICE_TITLE := 1&1 WLAN-MODEM - FRITZ7312
+ DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-mini \
+ kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
+ kmod-ltq-adsl-ar9-fw-b kmod-ltq-atm-ar9 \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ltq-deu-ar9 -swconfig
+endef
+TARGET_DEVICES += avm_fritz7312
+
define Device/avm_fritz7320
$(Device/AVM)
DEVICE_DTS := FRITZ7320